aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyzbar
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 00:40:31 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 00:41:05 +0200
commite4fdddff9eefaa1364a80a50441414989c3f5019 (patch)
tree93fb20209ae0f06faa0b0fb89153eef06c111817 /community/py3-pyzbar
parent000b8453724390313bf00abb52f39498e32f0e2a (diff)
downloadaports-e4fdddff9eefaa1364a80a50441414989c3f5019.tar.bz2
aports-e4fdddff9eefaa1364a80a50441414989c3f5019.tar.xz
community/py3-pyzbar: move from testing
Diffstat (limited to 'community/py3-pyzbar')
-rw-r--r--community/py3-pyzbar/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-pyzbar/APKBUILD b/community/py3-pyzbar/APKBUILD
new file mode 100644
index 0000000000..fe13e23250
--- /dev/null
+++ b/community/py3-pyzbar/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-pyzbar
+pkgver=0.1.8
+pkgrel=0
+pkgdesc="Read one-dimensional barcodes and QR codes from Python 3"
+url="https://github.com/NaturalHistoryMuseum/pyzbar/"
+arch="all"
+license="MIT"
+depends="python3 zbar"
+makedepends="python3-dev py3-setuptools"
+checkdepends="py3-coveralls py3-nose py3-numpy py3-pillow"
+source="py3-pyzbar-$pkgver.tar.gz::https://github.com/NaturalHistoryMuseum/pyzbar/archive/v$pkgver.tar.gz"
+builddir="$srcdir/pyzbar-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ [ "$CARCH" = s390x ] && return 0
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e186c7a2f29ec107f66b87a2901e128291747ef7a2159675f3170aef2a3a4b1f4cb4319da830d577c986e20abb3f2935e005361cc98857b0e1b880fb4cf40233 py3-pyzbar-0.1.8.tar.gz"