aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rencode/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 23:06:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 23:23:33 -0300
commit9f4458ceae490854765d7d5d0bcaafe080a51473 (patch)
tree8f5bd2a48e0255dc50760b75b1b91c2782c85fb4 /community/py3-rencode/APKBUILD
parent3e76c8e3d7c517c2cc5a7ec88c315a9796119301 (diff)
downloadaports-9f4458ceae490854765d7d5d0bcaafe080a51473.tar.bz2
aports-9f4458ceae490854765d7d5d0bcaafe080a51473.tar.xz
community/py3-rencode: drop py2
Diffstat (limited to 'community/py3-rencode/APKBUILD')
-rw-r--r--community/py3-rencode/APKBUILD38
1 files changed, 9 insertions, 29 deletions
diff --git a/community/py3-rencode/APKBUILD b/community/py3-rencode/APKBUILD
index a2e422e679..05bfb60a87 100644
--- a/community/py3-rencode/APKBUILD
+++ b/community/py3-rencode/APKBUILD
@@ -1,47 +1,27 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-rencode
+pkgname=py3-rencode
_pkgname=rencode
pkgver=1.0.6
-pkgrel=2
+pkgrel=3
pkgdesc="The rencode module is similar to bencode from the BitTorrent project."
+options="!check" # No testsuite
url="https://pypi.python.org/pypi/rencode"
arch="all"
license="GPL-3.0-or-later"
-makedepends="py-setuptools py3-setuptools python2-dev python3-dev cython2 cython3"
- subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="py3-setuptools python3-dev cython3"
source="$pkgname-$pkgver.tar.gz::https://github.com/aresch/rencode/archive/v$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-rencode" # Backwards compatibility
+provides="py-rencode=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
}
-sha512sums="f04de4d3a83aed916bdc4b7a8ca772655e9324d0531ee882cb7d2a1e92b397bdcec8497bf02939e0a806886ecc62ed2e7319dfee054dad1b69052157f0959e8f py-rencode-1.0.6.tar.gz"
+sha512sums="f04de4d3a83aed916bdc4b7a8ca772655e9324d0531ee882cb7d2a1e92b397bdcec8497bf02939e0a806886ecc62ed2e7319dfee054dad1b69052157f0959e8f py3-rencode-1.0.6.tar.gz"