aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rencode
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 23:04:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 23:23:33 -0300
commit3e76c8e3d7c517c2cc5a7ec88c315a9796119301 (patch)
treee7271c4365f0cb631ec496bfafbe0e58f0edd8a4 /community/py3-rencode
parent7d3ffdea5c31d16ff37f6969261fcc44191681ad (diff)
downloadaports-3e76c8e3d7c517c2cc5a7ec88c315a9796119301.tar.bz2
aports-3e76c8e3d7c517c2cc5a7ec88c315a9796119301.tar.xz
community/py3-rencode: rename from py-rencode
Diffstat (limited to 'community/py3-rencode')
-rw-r--r--community/py3-rencode/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/py3-rencode/APKBUILD b/community/py3-rencode/APKBUILD
new file mode 100644
index 0000000000..a2e422e679
--- /dev/null
+++ b/community/py3-rencode/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-rencode
+_pkgname=rencode
+pkgver=1.0.6
+pkgrel=2
+pkgdesc="The rencode module is similar to bencode from the BitTorrent project."
+url="https://pypi.python.org/pypi/rencode"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="py-setuptools py3-setuptools python2-dev python3-dev cython2 cython3"
+ subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/aresch/rencode/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="f04de4d3a83aed916bdc4b7a8ca772655e9324d0531ee882cb7d2a1e92b397bdcec8497bf02939e0a806886ecc62ed2e7319dfee054dad1b69052157f0959e8f py-rencode-1.0.6.tar.gz"