aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-reportlab
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-22 21:19:32 +0300
committerprspkt <prspkt@protonmail.com>2019-06-22 22:01:06 +0300
commit5abe542325c245ccb00a94c08a0d9306c1ddada5 (patch)
tree1feb890d291bac2fe7134f029dafbd2dc6d21139 /community/py3-reportlab
parent879b37c6ac7879dc417498fcd14d39c1d2eb947d (diff)
downloadaports-5abe542325c245ccb00a94c08a0d9306c1ddada5.tar.bz2
aports-5abe542325c245ccb00a94c08a0d9306c1ddada5.tar.xz
community/py-reportlab: drop python2
Diffstat (limited to 'community/py3-reportlab')
-rw-r--r--community/py3-reportlab/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/py3-reportlab/APKBUILD b/community/py3-reportlab/APKBUILD
new file mode 100644
index 0000000000..43cae40775
--- /dev/null
+++ b/community/py3-reportlab/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
+pkgname=py3-reportlab
+_pkgname=reportlab
+pkgver=3.4.0
+pkgrel=1
+pkgdesc="A proven industry-strength PDF generating solution"
+url="http://www.reportlab.org/rl_toolkit.html"
+arch="all"
+license="BSD"
+depends="py3-pillow ttf-dejavu"
+makedepends="freetype-dev py3-setuptools python3-dev"
+install=""
+source="https://pypi.python.org/packages/87/f9/53b34c58d3735a6df7d5c542bf4de60d699cfa6035e113ca08b3ecdcca3f/reportlab-$pkgver.tar.gz"
+builddir="$srcdir/reportlab-$pkgver"
+
+replaces="py-reportlab" # Backwards compatibility
+provides="py-reportlab=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="7f00074b93be49e1aa7650e61381e285598599911b12a6b63c0f12d6eb64bc59afb6907b683350740b0a81c99a3164373b27e18cfccc0f9da12405c3dacd1ff7 reportlab-3.4.0.tar.gz"