aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-requests-oauthlib
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-27 06:46:49 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-02 15:56:04 +0000
commit0751ab39d461d4e7fe172188768b12a05914e918 (patch)
tree07140a8e44841ca140b7c691813943b10b8e0f0a /community/py3-requests-oauthlib
parent124da9767588900000a0fc3e129a29c65e4e34c6 (diff)
downloadaports-0751ab39d461d4e7fe172188768b12a05914e918.tar.bz2
aports-0751ab39d461d4e7fe172188768b12a05914e918.tar.xz
community/py3-requests-oauthlib: move from community
Closes !212
Diffstat (limited to 'community/py3-requests-oauthlib')
-rw-r--r--community/py3-requests-oauthlib/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-requests-oauthlib/APKBUILD b/community/py3-requests-oauthlib/APKBUILD
new file mode 100644
index 0000000000..f4d474220c
--- /dev/null
+++ b/community/py3-requests-oauthlib/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer:
+pkgname=py3-requests-oauthlib
+_pkgname=requests-oauthlib
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="First-class OAuth library support for Requests"
+options="!check" # Requires 'requests-mock'
+url="https://pypi.python.org/pypi/requests-oauthlib"
+arch="noarch"
+license="ISC"
+depends="python3 py3-oauthlib py3-requests"
+makedepends="py3-setuptools"
+checkdepends="py3-mock"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-requests-oauthlib" # Backwards compatibility
+provides="py-requests-oauthlib=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="531cbea898b692864134b83479b3a32b0455def8bbd0b808a118bd63d377c4056e8df9a4943fa4048e5b27e2628641d8818d3bbc71dde91522a3be163da1e719 requests-oauthlib-1.2.0.tar.gz"