aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rpigpio
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 09:25:19 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 10:03:05 -0300
commitf81611c088c4833e1c76b4709a1a15e705056745 (patch)
treec4195ba99e1ea8d59e63c13a7b5ae1690e4c54f4 /community/py3-rpigpio
parent26060c72ec30cd2eabd0d72aba6d100fbebf9a18 (diff)
downloadaports-f81611c088c4833e1c76b4709a1a15e705056745.tar.bz2
aports-f81611c088c4833e1c76b4709a1a15e705056745.tar.xz
community/py3-rpigpio: rename from py-rpigpio
Diffstat (limited to 'community/py3-rpigpio')
-rw-r--r--community/py3-rpigpio/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/community/py3-rpigpio/APKBUILD b/community/py3-rpigpio/APKBUILD
new file mode 100644
index 0000000000..1088cf3b81
--- /dev/null
+++ b/community/py3-rpigpio/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=py-rpigpio
+_pkgname=RPi.GPIO
+pkgver=0.6.5
+pkgrel=1
+pkgdesc="This package provides a class to control the GPIO on a Raspberry Pi."
+url="https://pypi.python.org/pypi/RPi.GPIO"
+arch="armhf armv7"
+license="MIT"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="1393f49715b9c2d693743f962f75c4129ed229c83f49f31b913af8eaddb94280884127b8815d5c1e8451c3764c86962763a611b19ebc4afe72ac5fea3b61817b py-rpigpio-0.6.5.tar.gz"