aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rsa
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:48:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-02 01:43:47 +0000
commitaad2afe051973fa7fd6f4f9b83703c09445ff17c (patch)
tree4266144bb0c3984f784b0dd910d33fa98a72c353 /community/py3-rsa
parentaad758e364da9a69d0d519b619cc6eb2c7d150f8 (diff)
downloadaports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.bz2
aports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.xz
community/py3-*: move from main/ and modernize
Diffstat (limited to 'community/py3-rsa')
-rw-r--r--community/py3-rsa/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py3-rsa/APKBUILD b/community/py3-rsa/APKBUILD
new file mode 100644
index 0000000000..724270bed7
--- /dev/null
+++ b/community/py3-rsa/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer:
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+pkgname=py3-rsa
+_pkgname=rsa
+pkgver=3.4.2
+pkgrel=5
+pkgdesc="Pure-Python3 RSA implementation"
+url="https://stuvel.eu/rsa"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-asn1"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-rsa" # Backwards compatibility
+provides="py-rsa=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="62b0ff31fb3b9c18ae65bd102329e69726b853560576b1b66b9b89b26d3ff79154239af7e7a581b6a27c7017cc013f738762cd9662777ef594cc11c5b1f8e267 rsa-3.4.2.tar.gz"