aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rtslib
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-04-03 14:55:34 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-04 06:33:54 +0000
commitf342086f328dacdc48f28f6a146544de4c32c3dd (patch)
tree12463d701e656ad9eb496a8af00b985df27abff3 /community/py3-rtslib
parent47f423ab2506c081e0951a189c55afa613aca560 (diff)
downloadaports-f342086f328dacdc48f28f6a146544de4c32c3dd.tar.bz2
aports-f342086f328dacdc48f28f6a146544de4c32c3dd.tar.xz
community/py3-rtslib: use python3
Diffstat (limited to 'community/py3-rtslib')
-rw-r--r--community/py3-rtslib/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/py3-rtslib/APKBUILD b/community/py3-rtslib/APKBUILD
new file mode 100644
index 0000000000..bf9a796f5b
--- /dev/null
+++ b/community/py3-rtslib/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py3-rtslib
+_pkgname=rtslib-fb
+pkgver=2.1_p69
+_ver=${pkgver/_rc/rc}
+_ver=${_ver/_p/.fb}
+pkgrel=0
+pkgdesc="Python library that provides an object API to RisingTide Systems generic SCSI Target"
+url="https://github.com/open-iscsi/rtslib-fb"
+arch="noarch"
+license="AGPL-3.0"
+depends="python3"
+makedepends="$depends_dev py3-configobj py3-ethtool py3-ipaddr"
+source="https://github.com/open-iscsi/rtslib-fb/archive/v${_ver}.tar.gz"
+options="!check" # no test suite
+builddir="$srcdir"/${_pkgname}-${_ver}
+
+prepare() {
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir"
+# install -D -m644 specs/ib_srpt.spec $pkgdir/var/lib/target/fabric/ib_srpt.spec
+# install -D -m644 specs/iscsi.spec $pkgdir/var/lib/target/fabric/iscsi.spec
+# install -D -m644 specs/loopback.spec $pkgdir/var/lib/target/fabric/loopback.spec
+# install -D -m644 specs/qla2xxx.spec $pkgdir/var/lib/target/fabric/qla2xxx.spec
+# install -D -m644 specs/tcm_fc.spec $pkgdir/var/lib/target/fabric/tcm_fc.spec
+}
+
+sha512sums="552e660eb8aa26ac44f1ac089143a39e10106c1859db863c63ad5469e8ab0b0cdd0fba8f6fc30633cfd321ec0d72f6063ea0e8944aaa228de118400380b5418b v2.1.fb69.tar.gz"