aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ruamel.std.pathlib
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-04-15 09:09:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-17 11:45:42 +0000
commitfc008fd775a75a373199951ff6aaa166f4374716 (patch)
tree7797cd5d65ccfea8171e1996d884022330bbe89c /community/py3-ruamel.std.pathlib
parent5d8be6dedd145765a403772af3166b5177c780af (diff)
downloadaports-fc008fd775a75a373199951ff6aaa166f4374716.tar.bz2
aports-fc008fd775a75a373199951ff6aaa166f4374716.tar.xz
community/py3-ruamel.std.pathlib: rebuild against python 3.7
Diffstat (limited to 'community/py3-ruamel.std.pathlib')
-rw-r--r--community/py3-ruamel.std.pathlib/APKBUILD8
-rw-r--r--community/py3-ruamel.std.pathlib/python3.7.patch12
2 files changed, 17 insertions, 3 deletions
diff --git a/community/py3-ruamel.std.pathlib/APKBUILD b/community/py3-ruamel.std.pathlib/APKBUILD
index d78437ea3c..51e7c1dbcf 100644
--- a/community/py3-ruamel.std.pathlib/APKBUILD
+++ b/community/py3-ruamel.std.pathlib/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-ruamel.std.pathlib
_pyname=ruamel.std.pathlib
pkgver=0.6.3
-pkgrel=0
+pkgrel=1
pkgdesc="improvements over the standard pathlib module and pathlib2 package"
url=https://bitbucket.org/ruamel/std.pathlib
arch=noarch
@@ -11,7 +11,8 @@ license=MIT
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
-source="$_pyname-$pkgver.tar.gz::https://bitbucket.org/ruamel/std.pathlib/get/$pkgver.tar.gz"
+source="$_pyname-$pkgver.tar.gz::https://bitbucket.org/ruamel/std.pathlib/get/$pkgver.tar.gz
+ python3.7.patch"
# 79fff2a1baf7ae44c46415b5fac653cf4a7db9d2 0.6.3
builddir="$srcdir/ruamel-std.pathlib-79fff2a1baf7"
@@ -29,4 +30,5 @@ package() {
cd "$builddir"
python3 -m pip install . --prefix=/usr --root="$pkgdir"
}
-sha512sums="1210d8f7ae77c6358fc857c3ee447b2eb9802eaa31a210804acd74ec23dfd6ac9dec90dd7b21c79dcb4845dff4ad3614dd615c4798d3d7a39cc3a877cb9b63b0 ruamel.std.pathlib-0.6.3.tar.gz"
+sha512sums="1210d8f7ae77c6358fc857c3ee447b2eb9802eaa31a210804acd74ec23dfd6ac9dec90dd7b21c79dcb4845dff4ad3614dd615c4798d3d7a39cc3a877cb9b63b0 ruamel.std.pathlib-0.6.3.tar.gz
+51b2c1cebec4cefca455ba3f744f1dc40d2b2243b7df1d8911a5fd4f214c295f949b8556953a00c3a5c542f8bedccd2260466fd5c19f033572cd0f91504b80fd python3.7.patch"
diff --git a/community/py3-ruamel.std.pathlib/python3.7.patch b/community/py3-ruamel.std.pathlib/python3.7.patch
new file mode 100644
index 0000000000..b0e02c0b97
--- /dev/null
+++ b/community/py3-ruamel.std.pathlib/python3.7.patch
@@ -0,0 +1,12 @@
+diff --git a/__init__.py b/__init__.py
+index 3f4ace5..9e71492 100644
+--- a/__init__.py
++++ b/__init__.py
+@@ -14,6 +14,7 @@ _package_data = dict(
+ extras_require={
+ ':python_version<="3.4"': ['pathlib2', ],
+ },
++ keywords='',
+ license='MIT License',
+ universal=True,
+ tox=dict(