aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-scipy
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-13 22:37:38 +0300
committerprspkt <prspkt@protonmail.com>2019-08-13 23:04:35 +0300
commitc34c256f59b70473b74710d78fc8c6d3c235e6c4 (patch)
tree93439fdc7d6fb8ee8a3952455416cd9152d04331 /community/py3-scipy
parent25fb199b8c4103e4f59228033e9b8283b652bee4 (diff)
downloadaports-c34c256f59b70473b74710d78fc8c6d3c235e6c4.tar.bz2
aports-c34c256f59b70473b74710d78fc8c6d3c235e6c4.tar.xz
community/py-scipy: drop python2
* Clarify license, update url to use https. Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community/py3-scipy')
-rw-r--r--community/py3-scipy/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-scipy/APKBUILD b/community/py3-scipy/APKBUILD
new file mode 100644
index 0000000000..2ba0a276d7
--- /dev/null
+++ b/community/py3-scipy/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Martell Malone <martellmalone@gmail.com>
+# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+pkgname=py3-scipy
+pkgver=1.2.1
+pkgrel=4
+pkgdesc="Python library for scientific computing"
+url="https://www.scipy.org"
+arch="all"
+license="BSD-3-Clause"
+depends="py3-numpy-f2py"
+makedepends="cython gfortran openblas-dev>=0.3.0 py3-numpy-dev py3-setuptools
+ python3-dev"
+source="https://github.com/scipy/scipy/releases/download/v$pkgver/scipy-$pkgver.tar.xz"
+builddir="$srcdir"/scipy-$pkgver
+
+replaces=py-scipy # Backwards compatibility
+provides=py-scipy=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ export LDFLAGS="$LDFLAGS -shared"
+ python3 setup.py config_fc --fcompiler=gnu95 build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ebc75c9c40c5accb581c88e42fd3e96a26b42c6bd3785e6e84ace8b1f44fb836c83721c267fcdd9e8f573532056a74b150bde9316da4ac71aa33bd848cc49bd1 scipy-1.2.1.tar.xz"