aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-skia-pathops
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-01-04 18:12:01 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-01-04 22:29:56 +0100
commit5c756a2295dc2d86fea14ed399f673080719c365 (patch)
tree9654fb99187fc12b4ee708148745f913dfd22b45 /community/py3-skia-pathops
parentae427a18b9079bd5ec332a935a8dfcd68c281156 (diff)
downloadaports-5c756a2295dc2d86fea14ed399f673080719c365.tar.bz2
aports-5c756a2295dc2d86fea14ed399f673080719c365.tar.xz
community/py3-skia-pathops: move from testing
Diffstat (limited to 'community/py3-skia-pathops')
-rw-r--r--community/py3-skia-pathops/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-skia-pathops/APKBUILD b/community/py3-skia-pathops/APKBUILD
new file mode 100644
index 0000000000..b5b352446d
--- /dev/null
+++ b/community/py3-skia-pathops/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-skia-pathops
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="Python bindings for the Skia library's Path Ops"
+url="https://github.com/fonttools/skia-pathops"
+arch="all !s390x" # doesn't support big endian
+license="BSD-3-Clause"
+depends="python3 cython"
+makedepends="python3-dev py3-setuptools"
+options="!check" # missing deps: pytest-cython, pytest-randomly
+source="https://files.pythonhosted.org/packages/source/s/skia-pathops/skia-pathops-$pkgver.zip"
+builddir="$srcdir/skia-pathops-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ed4deba9e6e3576cc4c550c0c0172b0780f1e8e1424f156e8ef893a62924fd91c16a3bf2e1598c3116a1a73958513339dce48a2978f86b27f285d6f0f50245eb skia-pathops-0.2.1.zip"