aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-statmake
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-01-04 18:11:46 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-01-04 22:29:56 +0100
commit63daae90a03c2e6d0c672f501eee0d8beb46e10d (patch)
tree01ee466ee5639d52ea4e83cb37001454e2719b55 /community/py3-statmake
parentce3b399f3787a1df81704b7cbb082488c42cd453 (diff)
downloadaports-63daae90a03c2e6d0c672f501eee0d8beb46e10d.tar.bz2
aports-63daae90a03c2e6d0c672f501eee0d8beb46e10d.tar.xz
community/py3-statmake: move from testing
Diffstat (limited to 'community/py3-statmake')
-rw-r--r--community/py3-statmake/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/py3-statmake/APKBUILD b/community/py3-statmake/APKBUILD
new file mode 100644
index 0000000000..120cdcde93
--- /dev/null
+++ b/community/py3-statmake/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-statmake
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="Applies STAT information from a Stylespace to a variable font"
+url="https://github.com/daltonmaag/statmake"
+arch="noarch"
+license="MIT"
+depends="python3 py3-cattrs"
+makedepends="py3-setuptools"
+options="!check" # fail locally
+source="https://files.pythonhosted.org/packages/source/s/statmake/statmake-$pkgver.tar.gz"
+builddir="$srcdir/statmake-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="de1e1ced3ccdf3ba66f1100cc3910227b79c2076af8fbb05fb6e6939d0765d7f1f42e861909ec1c05439f0e1d94b2f133643c63f594ab454b15f640350549a45 statmake-0.2.0.tar.gz"