aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-text-unidecode/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-25 01:39:15 +0300
committerprspkt <prspkt@protonmail.com>2019-07-25 02:00:03 +0300
commit08a633919552ff4f797ab2990a0bfdd7bb2b5cac (patch)
tree43001dadf9886f7ccdec22b15ff45d93012a0de4 /community/py3-text-unidecode/APKBUILD
parent4a475b63904d25ac52b736c6b0f398437265f0d0 (diff)
downloadaports-08a633919552ff4f797ab2990a0bfdd7bb2b5cac.tar.bz2
aports-08a633919552ff4f797ab2990a0bfdd7bb2b5cac.tar.xz
community/py-text-unidecode: drop python2
Diffstat (limited to 'community/py3-text-unidecode/APKBUILD')
-rw-r--r--community/py3-text-unidecode/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-text-unidecode/APKBUILD b/community/py3-text-unidecode/APKBUILD
new file mode 100644
index 0000000000..a2182af263
--- /dev/null
+++ b/community/py3-text-unidecode/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py3-text-unidecode
+_pkgname=text-unidecode
+pkgver=1.2
+pkgrel=2
+pkgdesc="The most basic Text::Unidecode port"
+url=https://github.com/kmike/text-unidecode/
+arch=noarch
+license="Artistic-1.0-cl8"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kmike/$_pkgname/archive/$pkgver.tar.gz"
+builddir=$srcdir/$_pkgname-$pkgver
+
+replaces=py-text-unidecode # Backwards compatibility
+provides=py-text-unidecode=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH=src pytest-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ce4bd80f8343ebca031a39f1fbe802cd86e3535a67d5e16f8a7f32442ab334e4e5e4d1cf74e8a55ef265765c879bfde87beffd31ff988efff1947f7c883694f9 py3-text-unidecode-1.2.tar.gz"