aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-urwid
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-27 19:17:04 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-27 19:18:24 -0300
commit04f35e42baf55648c72c9d5986b3fb36c7432d4f (patch)
tree645f0a40868eb8909c0b27a35f2114da883203a6 /community/py3-urwid
parent4f8725f55dcfb8fc896601d2d46ff931b66e5b57 (diff)
downloadaports-04f35e42baf55648c72c9d5986b3fb36c7432d4f.tar.bz2
aports-04f35e42baf55648c72c9d5986b3fb36c7432d4f.tar.xz
community/py3-urwid: drop py2
Diffstat (limited to 'community/py3-urwid')
-rw-r--r--community/py3-urwid/APKBUILD50
1 files changed, 14 insertions, 36 deletions
diff --git a/community/py3-urwid/APKBUILD b/community/py3-urwid/APKBUILD
index 64d06dd2cc..868da7063a 100644
--- a/community/py3-urwid/APKBUILD
+++ b/community/py3-urwid/APKBUILD
@@ -1,55 +1,33 @@
# Contributor: Matt Smith <mcs@darkregion.net>
# Maintainer: Matt Smith <mcs@darkregion.net>
-pkgname=py-urwid
+pkgname=py3-urwid
_pkgname=urwid
pkgver=2.0.1
-pkgrel=0
-pkgdesc="A console user interface library for Python"
+pkgrel=1
+pkgdesc="A console user interface library for Python3"
+options="!check" # (failures=1)
url="http://urwid.org/"
arch="all"
license="LGPL-2.0-or-later"
-makedepends="python2-dev python3-dev py-setuptools"
-checkdepends="py-twisted py2-tornado py3-tornado" # twisted isn't packaged for python3
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+checkdepends="py3-twisted py3-tornado"
source="https://files.pythonhosted.org/packages/source/u/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-urwid" # Backwards compatibility
+provides="py-urwid=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
check() {
- cd "$builddir"
- python2 setup.py test
python3 setup.py test
}
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
sha512sums="99c86a26b08c624c23207ce8e587e8442bece1f522e0c788600ad5f01a4c679efff95dd947edade8b6f4adc376edca949a40c305f9d5ddaf6a0ff97f13c6da30 urwid-2.0.1.tar.gz"