aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-webcolors
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-08 21:05:29 +0300
committerprspkt <prspkt@protonmail.com>2019-06-08 21:10:37 +0300
commitaf3218595806cd93e4f0285ccf74714173714860 (patch)
treef7ca2d8e34d64ba1fe0d5554edc9ab156555f7d8 /community/py3-webcolors
parentc2cd7382b4654145fc422a55c29fd93fd98595c1 (diff)
downloadaports-af3218595806cd93e4f0285ccf74714173714860.tar.bz2
aports-af3218595806cd93e4f0285ccf74714173714860.tar.xz
community/py3-webcolors: add checkdepends and run test suite
Diffstat (limited to 'community/py3-webcolors')
-rw-r--r--community/py3-webcolors/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/community/py3-webcolors/APKBUILD b/community/py3-webcolors/APKBUILD
index 2eda9bb45c..36762ee196 100644
--- a/community/py3-webcolors/APKBUILD
+++ b/community/py3-webcolors/APKBUILD
@@ -10,6 +10,7 @@ arch="noarch"
license="BSD-3-Clause"
depends="py3-six"
makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-runner py3-six"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -20,6 +21,10 @@ build() {
python3 setup.py build
}
+check() {
+ python3 setup.py pytest
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}