aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-websocket-client
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 15:52:51 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 16:08:57 -0300
commit7c2e6e55c3809452ba6a412af5f3435f74f7295b (patch)
tree3e9c50769068a1a8650347106c8df1a621df0049 /community/py3-websocket-client
parentac0391c44b65ba4605807776df593c215b793bb5 (diff)
downloadaports-7c2e6e55c3809452ba6a412af5f3435f74f7295b.tar.bz2
aports-7c2e6e55c3809452ba6a412af5f3435f74f7295b.tar.xz
community/py3-websocket-client: rename from py-websocket-client
Diffstat (limited to 'community/py3-websocket-client')
-rw-r--r--community/py3-websocket-client/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/py3-websocket-client/APKBUILD b/community/py3-websocket-client/APKBUILD
new file mode 100644
index 0000000000..9083b123df
--- /dev/null
+++ b/community/py3-websocket-client/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-websocket-client
+_pkgname=websocket_client
+pkgver=0.56.0
+pkgrel=1
+pkgdesc="WebSocket client library for Python"
+url="https://github.com/liris/websocket-client"
+arch="noarch"
+license="LGPL"
+makedepends="python2-dev python3-dev py-setuptools py2-six py3-six"
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+source="https://files.pythonhosted.org/packages/source/w/websocket-client/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+_py3() {
+ _py python3
+}
+
+sha512sums="f61497b5fa6deea11d0e81c1c0d3092d1efba9bcdb3427a45f51b81059444a486a9aa6a4d046fc2aa805e855d2c8e68a4ba46669c05a45eb928251c50e2e3a50 websocket_client-0.56.0.tar.gz"