aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-websocket-client
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 15:54:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 16:08:58 -0300
commit95a53f6f000e94a65987e782697039d30dd2cf71 (patch)
tree5540dfa8ae21dfe4aed03c0db84e1c4201b77b1c /community/py3-websocket-client
parent7c2e6e55c3809452ba6a412af5f3435f74f7295b (diff)
downloadaports-95a53f6f000e94a65987e782697039d30dd2cf71.tar.bz2
aports-95a53f6f000e94a65987e782697039d30dd2cf71.tar.xz
community/py3-websocket-client: drop py2
Diffstat (limited to 'community/py3-websocket-client')
-rw-r--r--community/py3-websocket-client/APKBUILD36
1 files changed, 9 insertions, 27 deletions
diff --git a/community/py3-websocket-client/APKBUILD b/community/py3-websocket-client/APKBUILD
index 9083b123df..0f1b546033 100644
--- a/community/py3-websocket-client/APKBUILD
+++ b/community/py3-websocket-client/APKBUILD
@@ -1,49 +1,31 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-websocket-client
+pkgname=py3-websocket-client
_pkgname=websocket_client
pkgver=0.56.0
-pkgrel=1
+pkgrel=2
pkgdesc="WebSocket client library for Python"
url="https://github.com/liris/websocket-client"
arch="noarch"
-license="LGPL"
-makedepends="python2-dev python3-dev py-setuptools py2-six py3-six"
-subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+license="BSD-3-Clause"
+depends="python3 py3-six"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/w/websocket-client/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-websocket-client" # Backwards compatibility
+provides="py-websocket-client=$pkgver-r$pkgrel" # Backwards compatibility
+
check() {
- cd "$builddir"
- python2 setup.py check
python3 setup.py check
}
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- _py python2
- replaces="$pkgname"
-}
-
-_py3() {
- _py python3
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="f61497b5fa6deea11d0e81c1c0d3092d1efba9bcdb3427a45f51b81059444a486a9aa6a4d046fc2aa805e855d2c8e68a4ba46669c05a45eb928251c50e2e3a50 websocket_client-0.56.0.tar.gz"