aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-zipstream
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 15:41:08 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 16:12:05 -0300
commit130c0b02dbc9115c233f3ea4d6180fbe1c18b85d (patch)
tree12530916d94ecbdfd41aee08d8235e7d5310c9b9 /community/py3-zipstream
parent9a717bd76bd1edd5cce01b9f3a4431b0281429f3 (diff)
downloadaports-130c0b02dbc9115c233f3ea4d6180fbe1c18b85d.tar.bz2
aports-130c0b02dbc9115c233f3ea4d6180fbe1c18b85d.tar.xz
community/py3-zipstream: rename from py-zipstream
Diffstat (limited to 'community/py3-zipstream')
-rw-r--r--community/py3-zipstream/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/py3-zipstream/APKBUILD b/community/py3-zipstream/APKBUILD
new file mode 100644
index 0000000000..78bd4f86e0
--- /dev/null
+++ b/community/py3-zipstream/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-zipstream
+_pkgname=python-zipstream
+pkgver=1.1.4
+pkgrel=2
+pkgdesc="Like Python's ZipFile module, except it works as a generator that provides the file in many small chunks."
+url="https://github.com/allanlei/python-zipstream"
+arch="noarch"
+license="GPL-3.0"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/allanlei/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+_py3() {
+ _py python3
+}
+
+md5sums="18e2344412f3c46426e5df6cece33d6b py-zipstream-1.1.4.tar.gz"
+sha256sums="32a7a4bdb786914445589595273beffbbf9b6a0a3a3dc2cf19ea96114bd2abd7 py-zipstream-1.1.4.tar.gz"
+sha512sums="722c1d7db91dc47064fc51f1182417f46923b8f42a56e854f1fa125eaccfc7f86d3deab71709226a798a1caf5a84a8a7fa7d3564065ab91afbad434ed787ce32 py-zipstream-1.1.4.tar.gz"