aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-zope-deprecation
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 07:24:08 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 07:24:08 -0300
commit0224515a5c77e0114980724db9f5591ff76779c4 (patch)
treeb6e9d4b685776b514f8add52e03129621130169a /community/py3-zope-deprecation
parent02d787868f15fea73c74dd10006264740e964b35 (diff)
downloadaports-0224515a5c77e0114980724db9f5591ff76779c4.tar.bz2
aports-0224515a5c77e0114980724db9f5591ff76779c4.tar.xz
community/py3-zope-deprecation: rename from py-zope-deprecation
Diffstat (limited to 'community/py3-zope-deprecation')
-rw-r--r--community/py3-zope-deprecation/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/py3-zope-deprecation/APKBUILD b/community/py3-zope-deprecation/APKBUILD
new file mode 100644
index 0000000000..3d425fd32f
--- /dev/null
+++ b/community/py3-zope-deprecation/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-zope-deprecation
+_pkgname=zope.deprecation
+pkgver=4.4.0
+pkgrel=1
+pkgdesc="Zope Deprecation Infrastructure"
+url="https://pypi.python.org/pypi/zope.deprecation"
+arch="noarch"
+license="ZPL-2.1"
+depends="py-setuptools"
+makedepends="python2-dev python3-dev"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ python2 setup.py test
+ python3 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="62371dc45fad6715f24cdcac1d25b559ed5248da774b5ecd215fb4d0b6fc0ab655bfb9e0fbceda964e8ffb7d70536e43f8fcf09d9f2742904717a6473869fa4a zope.deprecation-4.4.0.tar.gz"