aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-zope-event
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 07:11:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 07:17:30 -0300
commita921c6cccb509eff870108c0ac57572365ac3228 (patch)
treec12e6ac0933427ac0a50baed2216df6bb3f952c4 /community/py3-zope-event
parent05ed2cee683f8e139b4c64c2c3f05ac54b497537 (diff)
downloadaports-a921c6cccb509eff870108c0ac57572365ac3228.tar.bz2
aports-a921c6cccb509eff870108c0ac57572365ac3228.tar.xz
community/py3-zope-event: drop py2
Diffstat (limited to 'community/py3-zope-event')
-rw-r--r--community/py3-zope-event/APKBUILD38
1 files changed, 8 insertions, 30 deletions
diff --git a/community/py3-zope-event/APKBUILD b/community/py3-zope-event/APKBUILD
index fdf6fe13af..f0808da61a 100644
--- a/community/py3-zope-event/APKBUILD
+++ b/community/py3-zope-event/APKBUILD
@@ -1,52 +1,30 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
-pkgname=py-zope-event
+pkgname=py3-zope-event
pkgver=4.4
-pkgrel=2
+pkgrel=3
pkgdesc="Event publishing / dispatch, used by Zope Component Architecture"
url="https://github.com/zopefoundation/zope.event"
arch="noarch"
license="ZPL-2.1"
-depends="py-setuptools"
-makedepends="python2-dev python3-dev"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-setuptools"
+# checkdepends="py3-zope-testrunner" # Is in upper repo
source="zope.event-$pkgver.tar.gz::https://github.com/zopefoundation/zope.event/archive/$pkgver.tar.gz"
-
builddir="$srcdir"/zope.event-$pkgver
+replaces="py-zope-event" # Backwards compatibility
+provides="py-zope-event=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
- python2 setup.py test
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}