aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-zope-hookable
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 07:16:40 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 07:18:12 -0300
commit02d787868f15fea73c74dd10006264740e964b35 (patch)
treee0f4179d3a49a8e5cbf227c9ed236bb2ed7242ef /community/py3-zope-hookable
parentacc8732bb0ad845fd43b1af2668528ad4c43806f (diff)
downloadaports-02d787868f15fea73c74dd10006264740e964b35.tar.bz2
aports-02d787868f15fea73c74dd10006264740e964b35.tar.xz
community/py3-zope-hookable: drop py2
Diffstat (limited to 'community/py3-zope-hookable')
-rw-r--r--community/py3-zope-hookable/APKBUILD39
1 files changed, 9 insertions, 30 deletions
diff --git a/community/py3-zope-hookable/APKBUILD b/community/py3-zope-hookable/APKBUILD
index caba0c7f36..ac1af3caf6 100644
--- a/community/py3-zope-hookable/APKBUILD
+++ b/community/py3-zope-hookable/APKBUILD
@@ -1,53 +1,32 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
-pkgname=py-zope-hookable
+pkgname=py3-zope-hookable
_pkgname=zope.hookable
pkgver=4.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="Represents the core of the Zope hookable Architecture"
url="https://github.com/zopefoundation/$_pkgname"
arch="all"
license="ZPL-2.1"
-depends="py-setuptools"
-makedepends="python2-dev python3-dev"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-setuptools"
+makedepends="python3-dev"
+# checkdepends="py3-zope-testing" # Is in upper repo 'testing'
source="$_pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/$_pkgname/archive/$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-zope-hookable" # Backwards compatibility
+provides="py-zope-hookable=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
- python2 setup.py test
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}