aboutsummaryrefslogtreecommitdiffstats
path: root/community/pytest
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-22 09:19:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-22 09:19:41 +0000
commite9997fb877cf6feeec14fc0392aab9053a5b046f (patch)
tree9a8469b89630047970c3abde6896c12d2d3c2b0a /community/pytest
parent6b528468cc91e29ef50a2a4832d9c2e389e5f235 (diff)
downloadaports-e9997fb877cf6feeec14fc0392aab9053a5b046f.tar.bz2
aports-e9997fb877cf6feeec14fc0392aab9053a5b046f.tar.xz
community/pytest: include subpackages deps in makedepends
We need to tell the builder that the dependencies for the subpackages needs to be built before pytest so they are available when pytest is needed. We do by adding the depends of subpacakges to the master makedepends. That way the proper build order can be calculated.
Diffstat (limited to 'community/pytest')
-rw-r--r--community/pytest/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/pytest/APKBUILD b/community/pytest/APKBUILD
index 0ef4724b60..f8a2122739 100644
--- a/community/pytest/APKBUILD
+++ b/community/pytest/APKBUILD
@@ -8,7 +8,9 @@ url="http://pytest.org"
arch="noarch"
license="MIT"
depends="py3-$pkgname"
-makedepends="python2-dev py-setuptools python3-dev"
+_py2_depends="py2-py py2-six py2-attrs py2-setuptools py2-more-itertools py2-pluggy py2-funcsigs"
+_py3_depends="py3-py py3-six py3-attrs py3-more-itertools py3-pluggy"
+makedepends="python2-dev py-setuptools python3-dev $_py2_depends $_py3_depends"
subpackages="py3-$pkgname:_py3 py2-$pkgname:_py2"
source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -35,12 +37,12 @@ package() {
_py2() {
replaces="$pkgname"
- depends="py2-py py2-six py2-attrs py2-setuptools py2-more-itertools py2-pluggy py2-funcsigs"
+ depends="$_py2_depends"
_py python2
}
_py3() {
- depends="py3-py py3-six py3-attrs py3-more-itertools py3-pluggy"
+ depends="$_py3_depends"
_py python3
}