aboutsummaryrefslogtreecommitdiffstats
path: root/community/qca/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-09 09:36:02 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-24 05:01:11 +0000
commit9cf86fe6d7031e7e9567884d3366020e7094fc0b (patch)
treef2bc8ce1a8f6d325c9b5717e5440f42025bfd023 /community/qca/APKBUILD
parent04871f410f95aede5e8c2982c909fdd904e45be4 (diff)
downloadaports-9cf86fe6d7031e7e9567884d3366020e7094fc0b.tar.bz2
aports-9cf86fe6d7031e7e9567884d3366020e7094fc0b.tar.xz
community/qca: upgrade to 2.2.1
Diffstat (limited to 'community/qca/APKBUILD')
-rw-r--r--community/qca/APKBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/community/qca/APKBUILD b/community/qca/APKBUILD
index 76e2e7888d..27840d9fcd 100644
--- a/community/qca/APKBUILD
+++ b/community/qca/APKBUILD
@@ -1,37 +1,34 @@
-# Contributor:
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qca
-pkgver=2.1.3
-pkgrel=6
+pkgver=2.2.1
+pkgrel=0
pkgdesc="Qt cryptographic architecture"
url="https://userbase.kde.org/QCA"
arch="all"
-license="LGPL"
-depends_dev="qt5-qtbase-dev"
-makedepends="$depends_dev cmake cyrus-sasl-dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://download.kde.org/stable/qca/$pkgver/src/qca-${pkgver}.tar.xz
- qca-openssl-1.1.patch
- "
-
-builddir="$srcdir"/qca-$pkgver
+license="LGPL-2.1-or-later"
+makedepends="qt5-qtbase-dev cmake cyrus-sasl-dev"
+subpackages="$pkgname-dev $pkgname-doc lib$pkgname:libs"
+source="https://download.kde.org/stable/qca/$pkgver/qca-${pkgver}.tar.xz"
build() {
- cd "$builddir"
cmake -DCMAKE_INSTALL_PREFIX=/usr -DWITH_cyrus-sasl_PLUGIN=yes .
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir"/usr/lib/qt5
+ mv "$pkgdir"/usr/mkspecs "$pkgdir"/usr/lib/qt5
}
check() {
- cd "$builddir"
make test
}
-sha512sums="0aec277e0695da2e45298f0a9006213829fe4c449a79969e472947db54f45000ba6e22361b782465bdc03f269b7301d318c843f5a83db459a118e58a03f3116a qca-2.1.3.tar.xz
-13eff6727ddcb1fdfd8d57175bcbee27dcbd60823d91b7b16224067908638ee8ae4b2a141e18b6038d4c0347ddc2011e04c0956309c15032b64ea0056fd7372a qca-openssl-1.1.patch"
+libs() {
+ default_libs
+ mv "$pkgdir"/usr/lib/qca-qt5 "$subpkgdir"/usr/lib
+}
+
+sha512sums="3a0e8aa7cf3ea9a7244facaf1d521ebca2753af37636e7bf5f21c57ae880ac9682ae7d6d9fa5ce41b73568ff9538214956b89cd41228c2cb828d9068c2031a9c qca-2.2.1.tar.xz"