aboutsummaryrefslogtreecommitdiffstats
path: root/community/qpdf/APKBUILD
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-05-09 12:02:54 +0100
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-05-20 10:47:37 +0000
commita2e9bd3630911c261b401b86bf5b549f67b79292 (patch)
tree517de7bf5a7fcbf7fc31fda93413cd595b8becb9 /community/qpdf/APKBUILD
parent9944847197251fbd799c9d58756b4f4885449abf (diff)
downloadaports-a2e9bd3630911c261b401b86bf5b549f67b79292.tar.bz2
aports-a2e9bd3630911c261b401b86bf5b549f67b79292.tar.xz
community/qpdf: move from main
Closes: GH-7106
Diffstat (limited to 'community/qpdf/APKBUILD')
-rw-r--r--community/qpdf/APKBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/community/qpdf/APKBUILD b/community/qpdf/APKBUILD
new file mode 100644
index 0000000000..9e69821b67
--- /dev/null
+++ b/community/qpdf/APKBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=qpdf
+pkgver=8.3.0
+pkgrel=0
+pkgdesc="Command-line tools and library for transforming PDF files"
+url="http://qpdf.sourceforge.net"
+arch="all"
+license="Apache-2.0"
+depends=""
+makedepends="zlib-dev libjpeg-turbo-dev bash"
+checkdepends="coreutils perl"
+install=""
+subpackages="$pkgname-dev
+ $pkgname-doc
+ $pkgname-libs
+ $pkgname-fix-qdf:fix_qdf:noarch
+ "
+source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+# secfixes:
+# 7.0.0-r0:
+# - CVE-2017-9208
+# - CVE-2017-9209
+# - CVE-2017-9210
+# - CVE-2017-11624
+# - CVE-2017-11625
+# - CVE-2017-11626
+# - CVE-2017-11627
+# - CVE-2017-12595
+
+prepare() {
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+fix_qdf() {
+ depends="qpdf perl"
+ pkgdesc="Repair PDF files in QDF form after editing"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/fix-qdf "$subpkgdir"/usr/bin/
+}
+
+sha512sums="9982a489cc6b9c880adc7decb18f1941930a86f430a00505f230364fbadf83c5afd832a1ccf7966a9453cdbb40b7c60db438f7b27d836a242eefb07a77d7284d qpdf-8.3.0.tar.gz"