aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtdeclarative
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-20 14:06:58 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-27 10:23:49 +0000
commit3f7df8f1c6e61942cea421df94545a2dff4943da (patch)
tree03f02479d2d03e3710bc01613c6f39b3197590a8 /community/qt5-qtdeclarative
parent880aa1b5c01e1e14f9295a953dbf37cbd08d24a9 (diff)
downloadaports-3f7df8f1c6e61942cea421df94545a2dff4943da.tar.bz2
aports-3f7df8f1c6e61942cea421df94545a2dff4943da.tar.xz
community/qt5-qtdeclarative: disable JIT on mips*
MIPS JIT code is broken in upstream, does not even compile.
Diffstat (limited to 'community/qt5-qtdeclarative')
-rw-r--r--community/qt5-qtdeclarative/APKBUILD9
-rw-r--r--community/qt5-qtdeclarative/disable-mips-jit.patch22
2 files changed, 28 insertions, 3 deletions
diff --git a/community/qt5-qtdeclarative/APKBUILD b/community/qt5-qtdeclarative/APKBUILD
index 26a6e6c23a..283f53ff60 100644
--- a/community/qt5-qtdeclarative/APKBUILD
+++ b/community/qt5-qtdeclarative/APKBUILD
@@ -7,7 +7,7 @@ _ver=${_ver/_/-}
_ver=${_ver/beta0/beta}
_ver=${_ver/rc0/rc}
_V=${_ver/rc/RC}
-pkgrel=0
+pkgrel=1
pkgdesc="Qt5 - QtDeclarative component"
url="http://qt-project.org/"
arch="all"
@@ -20,7 +20,9 @@ case $pkgver in
*) _rel=official_releases;;
esac
source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/$_pkgname-$_V.tar.xz
- qt-musl-stackbottom.patch"
+ qt-musl-stackbottom.patch
+ disable-mips-jit.patch
+ "
_qt5_prefix=/usr/lib/qt5
builddir="$srcdir"/$_pkgname-${_V%-*}
@@ -46,4 +48,5 @@ package() {
}
sha512sums="b45b7c2232a3e7ddc8076066957f5c110a0ca9c815ee659f6e7656e85175a9ae56c52d6402d5437e4b60cd86508eb3c912ddd441e0be0ac9590ea263ad397048 qtdeclarative-everywhere-src-5.10.1.tar.xz
-235091cc1da51c31165a99932c95543d999c0f21b2c6b4318306b647662d420f88d7270ec21db7417fe9f8d87bfa3e5f01b6465c3542da024dd1623ef0a87681 qt-musl-stackbottom.patch"
+235091cc1da51c31165a99932c95543d999c0f21b2c6b4318306b647662d420f88d7270ec21db7417fe9f8d87bfa3e5f01b6465c3542da024dd1623ef0a87681 qt-musl-stackbottom.patch
+03f945fd8f0a8affcaffb229b0b5f6bc1ebbc40b34bf83944779ad4fa85094e2f131dcd19b6c119b482441cd821054f3ad93f531919ad2211f3193ebe8cee156 disable-mips-jit.patch"
diff --git a/community/qt5-qtdeclarative/disable-mips-jit.patch b/community/qt5-qtdeclarative/disable-mips-jit.patch
new file mode 100644
index 0000000000..445d400a82
--- /dev/null
+++ b/community/qt5-qtdeclarative/disable-mips-jit.patch
@@ -0,0 +1,22 @@
+--- a/src/qml/jit/qv4targetplatform_p.h
++++ b/src/qml/jit/qv4targetplatform_p.h
+@@ -604,7 +604,7 @@
+ };
+ #endif // ARM64
+
+-#if defined(Q_PROCESSOR_MIPS_32) && defined(Q_OS_LINUX)
++#if defined(Q_PROCESSOR_MIPS_32) && defined(Q_OS_LINUX) && 0
+ template <>
+ class TargetPlatform<JSC::MacroAssemblerMIPS, NoOperatingSystemSpecialization>
+ {
+--- a/src/qml/jsruntime/qv4global_p.h
++++ b/src/qml/jsruntime/qv4global_p.h
+@@ -107,7 +107,7 @@
+ # if defined(Q_OS_LINUX) || defined(Q_OS_QNX)
+ # define V4_ENABLE_JIT
+ # endif
+-#elif defined(Q_PROCESSOR_MIPS_32) && defined(Q_OS_LINUX)
++#elif defined(Q_PROCESSOR_MIPS_32) && defined(Q_OS_LINUX) && 0
+ # define V4_ENABLE_JIT
+ #endif
+