aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtwebengine
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-29 11:41:06 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-29 11:41:06 +0000
commitcae0503cdb287df2afc7607567efe99a077db1e4 (patch)
tree64cc2c8bb20915481631e3d3d8595d72f5939234 /community/qt5-qtwebengine
parent708b95a9dd94a00a59f6493687dab2a1b044b522 (diff)
downloadaports-cae0503cdb287df2afc7607567efe99a077db1e4.tar.bz2
aports-cae0503cdb287df2afc7607567efe99a077db1e4.tar.xz
community/qt5-qtwebengine: build fix for arm
https://bugreports.qt.io/browse/QTBUG-72393
Diffstat (limited to 'community/qt5-qtwebengine')
-rw-r--r--community/qt5-qtwebengine/APKBUILD4
-rw-r--r--community/qt5-qtwebengine/arm-missing-files.patch205
2 files changed, 208 insertions, 1 deletions
diff --git a/community/qt5-qtwebengine/APKBUILD b/community/qt5-qtwebengine/APKBUILD
index ed43c1b393..ff195a0245 100644
--- a/community/qt5-qtwebengine/APKBUILD
+++ b/community/qt5-qtwebengine/APKBUILD
@@ -79,6 +79,7 @@ source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/qt
qt-musl-thread-stacksize.patch
musl-sandbox.patch
yasm-nls.patch
+ arm-missing-files.patch
"
builddir="$srcdir"/qtwebengine-everywhere-src-$_V
@@ -113,4 +114,5 @@ b1f7823d0bdd14dbcb4dbd72ab2d16460d343722d2601921a50f8912ce580a632e0d7b01d7fea6f2
7dc3e9995596adef65cd96f650eb7ee13d52cabfe6353f04eeb5b8a5776e7e0585ffc2a0a31deea6924352ee9a5a8e03ac37432b558c6a46f3dc457b4283392a qt-musl-stackstart.patch
b37fbc4df03c82123f94982039defa12d9bb8c885c9dcf8fff556b5f9cc58182fa471f970cc3a5e2d5dbe964855f591b474366b6a8926d94ae6a78e883811c1a qt-musl-thread-stacksize.patch
635d77109b5ce9bc9697d621f1bf98193903e2ac69fc4079fb92f175daa80147fed8ae15544d239ef680e120474d8f811002935ef1a078836ba01695f9ddfcb9 musl-sandbox.patch
-f6b1941e40f44b675ab554166e3cd8d3272b23f48571b4949b3af7b8e1c642ee84fe0ee26dd2457fc3bf20e9924cddb411e293b7a8a103029ee196587371a1e2 yasm-nls.patch"
+f6b1941e40f44b675ab554166e3cd8d3272b23f48571b4949b3af7b8e1c642ee84fe0ee26dd2457fc3bf20e9924cddb411e293b7a8a103029ee196587371a1e2 yasm-nls.patch
+2f99cb38352c34281508cbd1e676bffc4ed6835b68d59e871bb7f4a3898d5735c6455e9ea7fe00c22770a2e0238282eb98e0faddd597b63dfda5ab65acdf1d97 arm-missing-files.patch"
diff --git a/community/qt5-qtwebengine/arm-missing-files.patch b/community/qt5-qtwebengine/arm-missing-files.patch
new file mode 100644
index 0000000000..59af5db01c
--- /dev/null
+++ b/community/qt5-qtwebengine/arm-missing-files.patch
@@ -0,0 +1,205 @@
+From bf9a9d0532d7749901082ffce976d182672c2d36 Mon Sep 17 00:00:00 2001
+From: Allan Sandfeld Jensen <allan.jensen@qt.io>
+Date: Mon, 10 Dec 2018 14:35:22 +0100
+Subject: [PATCH] Fix building gn on arm
+
+Two arm header files were missing.
+
+Change-Id: I3d9cd03c682b9de6b38e75085bcda9deef81b5fa
+Fixes: QTBUG-72393
+Reviewed-by: Michal Klocek <michal.klocek@qt.io>
+---
+ gn/base/numerics/safe_conversions_arm_impl.h | 51 +++++++++++
+ gn/base/numerics/safe_math_arm_impl.h | 122 +++++++++++++++++++++++++++
+ 2 files changed, 173 insertions(+)
+ create mode 100644 gn/base/numerics/safe_conversions_arm_impl.h
+ create mode 100644 gn/base/numerics/safe_math_arm_impl.h
+
+diff --git a/src/3rdparty/gn/base/numerics/safe_conversions_arm_impl.h b/src/3rdparty/gn/base/numerics/safe_conversions_arm_impl.h
+new file mode 100644
+index 0000000000..da5813f65e
+--- /dev/null
++++ b/src/3rdparty/gn/base/numerics/safe_conversions_arm_impl.h
+@@ -0,0 +1,51 @@
++// Copyright 2017 The Chromium Authors. All rights reserved.
++// Use of this source code is governed by a BSD-style license that can be
++// found in the LICENSE file.
++
++#ifndef BASE_NUMERICS_SAFE_CONVERSIONS_ARM_IMPL_H_
++#define BASE_NUMERICS_SAFE_CONVERSIONS_ARM_IMPL_H_
++
++#include <cassert>
++#include <limits>
++#include <type_traits>
++
++#include "base/numerics/safe_conversions_impl.h"
++
++namespace base {
++namespace internal {
++
++// Fast saturation to a destination type.
++template <typename Dst, typename Src>
++struct SaturateFastAsmOp {
++ static const bool is_supported =
++ std::is_signed<Src>::value && std::is_integral<Dst>::value &&
++ std::is_integral<Src>::value &&
++ IntegerBitsPlusSign<Src>::value <= IntegerBitsPlusSign<int32_t>::value &&
++ IntegerBitsPlusSign<Dst>::value <= IntegerBitsPlusSign<int32_t>::value &&
++ !IsTypeInRangeForNumericType<Dst, Src>::value;
++
++ __attribute__((always_inline)) static Dst Do(Src value) {
++ int32_t src = value;
++ typename std::conditional<std::is_signed<Dst>::value, int32_t,
++ uint32_t>::type result;
++ if (std::is_signed<Dst>::value) {
++ asm("ssat %[dst], %[shift], %[src]"
++ : [dst] "=r"(result)
++ : [src] "r"(src), [shift] "n"(IntegerBitsPlusSign<Dst>::value <= 32
++ ? IntegerBitsPlusSign<Dst>::value
++ : 32));
++ } else {
++ asm("usat %[dst], %[shift], %[src]"
++ : [dst] "=r"(result)
++ : [src] "r"(src), [shift] "n"(IntegerBitsPlusSign<Dst>::value < 32
++ ? IntegerBitsPlusSign<Dst>::value
++ : 31));
++ }
++ return static_cast<Dst>(result);
++ }
++};
++
++} // namespace internal
++} // namespace base
++
++#endif // BASE_NUMERICS_SAFE_CONVERSIONS_ARM_IMPL_H_
+diff --git a/src/3rdparty/gn/base/numerics/safe_math_arm_impl.h b/src/3rdparty/gn/base/numerics/safe_math_arm_impl.h
+new file mode 100644
+index 0000000000..a7cda1bb23
+--- /dev/null
++++ b/src/3rdparty/gn/base/numerics/safe_math_arm_impl.h
+@@ -0,0 +1,122 @@
++// Copyright 2017 The Chromium Authors. All rights reserved.
++// Use of this source code is governed by a BSD-style license that can be
++// found in the LICENSE file.
++
++#ifndef BASE_NUMERICS_SAFE_MATH_ARM_IMPL_H_
++#define BASE_NUMERICS_SAFE_MATH_ARM_IMPL_H_
++
++#include <cassert>
++#include <limits>
++#include <type_traits>
++
++#include "base/numerics/safe_conversions.h"
++
++namespace base {
++namespace internal {
++
++template <typename T, typename U>
++struct CheckedMulFastAsmOp {
++ static const bool is_supported =
++ FastIntegerArithmeticPromotion<T, U>::is_contained;
++
++ // The following is much more efficient than the Clang and GCC builtins for
++ // performing overflow-checked multiplication when a twice wider type is
++ // available. The below compiles down to 2-3 instructions, depending on the
++ // width of the types in use.
++ // As an example, an int32_t multiply compiles to:
++ // smull r0, r1, r0, r1
++ // cmp r1, r1, asr #31
++ // And an int16_t multiply compiles to:
++ // smulbb r1, r1, r0
++ // asr r2, r1, #16
++ // cmp r2, r1, asr #15
++ template <typename V>
++ __attribute__((always_inline)) static bool Do(T x, U y, V* result) {
++ using Promotion = typename FastIntegerArithmeticPromotion<T, U>::type;
++ Promotion presult;
++
++ presult = static_cast<Promotion>(x) * static_cast<Promotion>(y);
++ *result = static_cast<V>(presult);
++ return IsValueInRangeForNumericType<V>(presult);
++ }
++};
++
++template <typename T, typename U>
++struct ClampedAddFastAsmOp {
++ static const bool is_supported =
++ BigEnoughPromotion<T, U>::is_contained &&
++ IsTypeInRangeForNumericType<
++ int32_t,
++ typename BigEnoughPromotion<T, U>::type>::value;
++
++ template <typename V>
++ __attribute__((always_inline)) static V Do(T x, U y) {
++ // This will get promoted to an int, so let the compiler do whatever is
++ // clever and rely on the saturated cast to bounds check.
++ if (IsIntegerArithmeticSafe<int, T, U>::value)
++ return saturated_cast<V>(x + y);
++
++ int32_t result;
++ int32_t x_i32 = x;
++ int32_t y_i32 = y;
++
++ asm("qadd %[result], %[first], %[second]"
++ : [result] "=r"(result)
++ : [first] "r"(x_i32), [second] "r"(y_i32));
++ return saturated_cast<V>(result);
++ }
++};
++
++template <typename T, typename U>
++struct ClampedSubFastAsmOp {
++ static const bool is_supported =
++ BigEnoughPromotion<T, U>::is_contained &&
++ IsTypeInRangeForNumericType<
++ int32_t,
++ typename BigEnoughPromotion<T, U>::type>::value;
++
++ template <typename V>
++ __attribute__((always_inline)) static V Do(T x, U y) {
++ // This will get promoted to an int, so let the compiler do whatever is
++ // clever and rely on the saturated cast to bounds check.
++ if (IsIntegerArithmeticSafe<int, T, U>::value)
++ return saturated_cast<V>(x - y);
++
++ int32_t result;
++ int32_t x_i32 = x;
++ int32_t y_i32 = y;
++
++ asm("qsub %[result], %[first], %[second]"
++ : [result] "=r"(result)
++ : [first] "r"(x_i32), [second] "r"(y_i32));
++ return saturated_cast<V>(result);
++ }
++};
++
++template <typename T, typename U>
++struct ClampedMulFastAsmOp {
++ static const bool is_supported = CheckedMulFastAsmOp<T, U>::is_supported;
++
++ template <typename V>
++ __attribute__((always_inline)) static V Do(T x, U y) {
++ // Use the CheckedMulFastAsmOp for full-width 32-bit values, because
++ // it's fewer instructions than promoting and then saturating.
++ if (!IsIntegerArithmeticSafe<int32_t, T, U>::value &&
++ !IsIntegerArithmeticSafe<uint32_t, T, U>::value) {
++ V result;
++ if (CheckedMulFastAsmOp<T, U>::Do(x, y, &result))
++ return result;
++ return CommonMaxOrMin<V>(IsValueNegative(x) ^ IsValueNegative(y));
++ }
++
++ assert((FastIntegerArithmeticPromotion<T, U>::is_contained));
++ using Promotion = typename FastIntegerArithmeticPromotion<T, U>::type;
++ return saturated_cast<V>(static_cast<Promotion>(x) *
++ static_cast<Promotion>(y));
++ }
++};
++
++} // namespace internal
++} // namespace base
++
++#endif // BASE_NUMERICS_SAFE_MATH_ARM_IMPL_H_
+--
+2.16.3
+