aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtwebkit
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-14 14:23:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-14 14:47:01 +0000
commit5b4b0cf8681f025b7f690669d88f2244e3ac0773 (patch)
treeef48215c2fa012e655ee6b731a7e696e92b7ec32 /community/qt5-qtwebkit
parent8e6d806d685d7ac7b6543f0b1a91b3ca1e327ac1 (diff)
downloadaports-5b4b0cf8681f025b7f690669d88f2244e3ac0773.tar.bz2
aports-5b4b0cf8681f025b7f690669d88f2244e3ac0773.tar.xz
community/qt5-qt*: move from main
Diffstat (limited to 'community/qt5-qtwebkit')
-rw-r--r--community/qt5-qtwebkit/0001-Add-ARM-64-support.patch13
-rw-r--r--community/qt5-qtwebkit/APKBUILD86
-rw-r--r--community/qt5-qtwebkit/fix-execinfo.patch20
-rw-r--r--community/qt5-qtwebkit/fix-rpath.patch11
-rw-r--r--community/qt5-qtwebkit/pic.patch11
5 files changed, 141 insertions, 0 deletions
diff --git a/community/qt5-qtwebkit/0001-Add-ARM-64-support.patch b/community/qt5-qtwebkit/0001-Add-ARM-64-support.patch
new file mode 100644
index 0000000000..73f5c97f87
--- /dev/null
+++ b/community/qt5-qtwebkit/0001-Add-ARM-64-support.patch
@@ -0,0 +1,13 @@
+diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
+index 4594ec8..639f28f 100644
+--- a/Source/WTF/wtf/Platform.h
++++ b/Source/WTF/wtf/Platform.h
+@@ -342,7 +342,7 @@
+ #endif
+ #endif
+
+-#if CPU(ARM) || CPU(MIPS) || CPU(SH4) || CPU(SPARC) || CPU(MIPS64)
++#if CPU(ARM) || CPU(MIPS) || CPU(SH4) || CPU(SPARC) || CPU(MIPS64) || CPU(AARCH64)
+ #define WTF_CPU_NEEDS_ALIGNED_ACCESS 1
+ #endif
+
diff --git a/community/qt5-qtwebkit/APKBUILD b/community/qt5-qtwebkit/APKBUILD
new file mode 100644
index 0000000000..3006b4063c
--- /dev/null
+++ b/community/qt5-qtwebkit/APKBUILD
@@ -0,0 +1,86 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=qt5-qtwebkit
+pkgver=5.8.0
+pkgrel=0
+pkgdesc="Qt5 - QtWebKit components"
+url="http://qt-project.org/"
+arch="all"
+license="LGPLv2 with exceptions or GPLv3 with exceptions"
+depends=""
+depends_dev="qt5-qtdeclarative-dev gstreamer1-dev gst-plugins-base1-dev
+ libxslt-dev mesa-dev icu-dev libxext-dev glib-dev libxcomposite-dev
+ libxrender-dev
+ "
+makedepends="$depends_dev
+ bison
+ flex
+ fontconfig-dev
+ gperf
+ libjpeg-turbo-dev
+ libpng-dev
+ libwebp-dev
+ pcre-dev
+ qt5-qtbase-dev
+ ruby
+ sqlite-dev
+ zlib-dev
+ "
+subpackages="$pkgname-dev"
+
+_ver=${pkgver/_/-}
+_ver=${_ver/beta0/beta}
+_ver=${_ver/rc0/rc}
+_V=${_ver/rc/RC}
+case $pkgver in
+*_beta*|*_rc*) _rel=development_releases;;
+*) _rel=official_releases;;
+esac
+
+source="http://download.qt.io/community_releases/${_V%.*}/${_V}-final/qtwebkit-opensource-src-$_V.tar.xz
+ pic.patch
+ fix-rpath.patch
+ fix-execinfo.patch
+ 0001-Add-ARM-64-support.patch
+ "
+builddir="$srcdir"/qtwebkit-opensource-src-$_V
+
+prepare() {
+ default_prepare || return 1 # apply patches
+ # remove some bundled
+ mkdir Source/ThirdParty/orig
+ mv Source/ThirdParty/gtest/ \
+ Source/ThirdParty/qunit/ \
+ Source/ThirdParty/orig/ \
+ || return 1
+ syncqt-qt5.pl -version $_V Source/sync.profile || return 1
+}
+
+build() {
+ cd "$builddir"
+ qmake-qt5 || return 1
+
+ # /usr/include/fortify/stdlib.h:20:25: fatal error: stdlib.h: No such file or directory
+ # see: http://stackoverflow.com/questions/37218953/isystem-on-a-system-include-directory-causes-errors
+ # see: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71090
+ # see: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129
+ qmake-qt5 Source/JavaScriptCore/LLIntOffsetsExtractor.pro -o \
+ Source/JavaScriptCore/Makefile.LLIntOffsetsExtractor || return 1
+ sed -i 's:-isystem /usr/include ::' \
+ Source/JavaScriptCore/Makefile.LLIntOffsetsExtractor || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir" || return 1
+ # remove rpath
+# chrpath --delete "$pkgdir"/usr/lib/qt5/libexec/* || return 1
+ sed -i -e 's:-L/home[^ ]\+::g' "$pkgdir"/usr/lib/pkgconfig/*.pc
+}
+
+sha512sums="980b5d267d31911f96822656d33407749eb7aa705d17051fe024505d51b0a6418cbd3492ba703057e8e22b0b1242a923f8b119ef9d52b70b7e6c28f36b2c9b84 qtwebkit-opensource-src-5.8.0.tar.xz
+9a62a5e7af91c44311b517608262f88b5bc607e75dc5878dd08b0a0872ec03fb7a566df0a41413f7e60beb1b9880e24f084b90c38ed50d4219ec2ad6af9bd62f pic.patch
+00d59c0cdb58ae8e7cf6bc3d03f133697e74c267ccebe12238bcdc274d4c90210b82c2d8bdf0e949cd43da13a4fd8a4c35fb54a00ed5102a4ac4d23aa002d0fe fix-rpath.patch
+f17c2f4b90090c8f12e4ba1f2cbd7a9f496c8de024ba6e0d55b98e5b89ab89298aff84f39e81905e0491fe6bd11544633a8b191403a866e16ed654d44cf8dc6f fix-execinfo.patch
+af5097d44f73de156ca31a5423136301dfc12ae693e20c4702bf3f1c6e16395f3912e9268582480ba3177021f37d4cae3b84d4b23eeb063fdc40f2444d3b34c8 0001-Add-ARM-64-support.patch"
diff --git a/community/qt5-qtwebkit/fix-execinfo.patch b/community/qt5-qtwebkit/fix-execinfo.patch
new file mode 100644
index 0000000000..6fbf4ed8fd
--- /dev/null
+++ b/community/qt5-qtwebkit/fix-execinfo.patch
@@ -0,0 +1,20 @@
+--- webkitgtk-2.2.0.orig/Source/WTF/wtf/Assertions.cpp
++++ webkitgtk-2.2.0/Source/WTF/wtf/Assertions.cpp
+@@ -64,7 +64,7 @@
+ #include <windows.h>
+ #endif
+
+-#if (OS(DARWIN) || (OS(LINUX) && !defined(__UCLIBC__))) && !OS(ANDROID)
++#if OS(DARWIN) || (OS(LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)) && !OS(ANDROID)
+ #include <cxxabi.h>
+ #include <dlfcn.h>
+ #include <execinfo.h>
+@@ -242,7 +242,7 @@
+
+ void WTFGetBacktrace(void** stack, int* size)
+ {
+-#if (OS(DARWIN) || (OS(LINUX) && !defined(__UCLIBC__))) && !OS(ANDROID)
++#if OS(DARWIN) || (OS(LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)) && !OS(ANDROID)
+ *size = backtrace(stack, *size);
+ #elif OS(WINDOWS) && !OS(WINCE)
+ // The CaptureStackBackTrace function is available in XP, but it is not defined
diff --git a/community/qt5-qtwebkit/fix-rpath.patch b/community/qt5-qtwebkit/fix-rpath.patch
new file mode 100644
index 0000000000..6b08fd1a39
--- /dev/null
+++ b/community/qt5-qtwebkit/fix-rpath.patch
@@ -0,0 +1,11 @@
+--- ./Tools/qmake/mkspecs/features/unix/default_post.prf.orig
++++ ./Tools/qmake/mkspecs/features/unix/default_post.prf
+@@ -59,8 +59,6 @@
+ }
+ }
+
+-contains(TEMPLATE, app): CONFIG += rpath
+-
+ CONFIG(debug, debug|release)|force_debug_info {
+ # Make ld not cache the symbol tables of input files in memory to avoid memory exhaustion during the linking phase.
+ !force_static_libs_as_shared:config_gnuld: QMAKE_LFLAGS += -Wl,--no-keep-memory
diff --git a/community/qt5-qtwebkit/pic.patch b/community/qt5-qtwebkit/pic.patch
new file mode 100644
index 0000000000..ef8993ee3d
--- /dev/null
+++ b/community/qt5-qtwebkit/pic.patch
@@ -0,0 +1,11 @@
+--- ./Source/WTF/wtf/InlineASM.h.orig 2013-10-07 11:36:58.995128674 +0000
++++ ./Source/WTF/wtf/InlineASM.h 2013-10-07 11:37:28.058792290 +0000
+@@ -42,7 +42,7 @@
+ #define THUMB_FUNC_PARAM(name)
+ #endif
+
+-#if (OS(LINUX) || OS(FREEBSD)) && CPU(X86_64)
++#if (OS(LINUX) || OS(FREEBSD)) && (CPU(X86_64) || defined(__PIC__))
+ #define GLOBAL_REFERENCE(name) #name "@plt"
+ #elif CPU(X86) && COMPILER(MINGW)
+ #define GLOBAL_REFERENCE(name) "@" #name "@4"