aboutsummaryrefslogtreecommitdiffstats
path: root/community/quazip
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-08 10:02:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-08 10:02:49 +0000
commitae25ce2088e1da7ae404c8d15e48a5a09cf13289 (patch)
tree7c6ef997e1bd1622a1269f04fccec94c95de9892 /community/quazip
parent01206f5373a503e92173da62e83e58ac21531263 (diff)
downloadaports-ae25ce2088e1da7ae404c8d15e48a5a09cf13289.tar.bz2
aports-ae25ce2088e1da7ae404c8d15e48a5a09cf13289.tar.xz
community/qazip: move from main
Diffstat (limited to 'community/quazip')
-rw-r--r--community/quazip/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/quazip/APKBUILD b/community/quazip/APKBUILD
new file mode 100644
index 0000000000..9cc48e3080
--- /dev/null
+++ b/community/quazip/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=quazip
+pkgver=0.7.3
+pkgrel=0
+pkgdesc="C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package"
+url="https://sourceforge.net/projects/quazip/"
+arch="all"
+license="LGPL"
+makedepends="qt-dev cmake"
+subpackages="$pkgname-dev"
+source="https://downloads.sourceforge.net/quazip/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ qmake PREFIX=/usr
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install
+}
+
+sha512sums="d4b55bd040e47e97e7bd5d080399ae4aa5fbc4985d6ab5979b468abc852c91b2e3e5d35af90d4b4de3bb01ea9135d0247473d6eab0413392b1c8567dc799a9fe quazip-0.7.3.tar.gz"