aboutsummaryrefslogtreecommitdiffstats
path: root/community/quazip
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-08 08:03:44 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-08 11:54:04 +0000
commita49d405135de6dac503d819fa22471d5d9ad0061 (patch)
tree45466c04ac233a15a84dab045a2aba16d5490d9d /community/quazip
parentaad5a8a8108c7eb9cbe303caab51bb49a6eb9886 (diff)
downloadaports-a49d405135de6dac503d819fa22471d5d9ad0061.tar.bz2
aports-a49d405135de6dac503d819fa22471d5d9ad0061.tar.xz
community/quazip: fixup
- Fix license - Disable check with comment
Diffstat (limited to 'community/quazip')
-rw-r--r--community/quazip/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/quazip/APKBUILD b/community/quazip/APKBUILD
index 3adc0b4ffd..975006ad0f 100644
--- a/community/quazip/APKBUILD
+++ b/community/quazip/APKBUILD
@@ -1,26 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=quazip
pkgver=0.7.6
-pkgrel=0
+pkgrel=1
pkgdesc="C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package"
+options="!check" # Has no testsuite
url="https://sourceforge.net/projects/quazip/"
arch="all"
-license="LGPL"
+# Has custom static linking exception
+license="LGPL-2.1-or-later WITH custom-static-linking-exception"
makedepends="qt5-qtbase-dev cmake"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-dev $pkgname-doc"
source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+replaces="quazip-qt5"
build() {
- cd "$builddir"
qmake-qt5 PREFIX=/usr
make
}
package() {
- cd "$builddir"
make INSTALL_ROOT="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
sha512sums="4325a69918216bb66c6a7c53589ef73473c3752151522a135dd9c92dbf722b29656aea7be0314c84399a214391eca79296ecda5811ab31845d8cf53c010110d1 quazip-0.7.6.tar.gz"