aboutsummaryrefslogtreecommitdiffstats
path: root/community/radare2/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-06-27 17:40:43 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-06-27 17:40:43 +0200
commit6c7cdd83eb8533325dbc46b6899b87fc14c8cd2e (patch)
treec88e13a596a1eefaa3a71e54a7541a485cc3fbad /community/radare2/APKBUILD
parenteb6df431e0b2a41e3df419e4bd72948a03d0b6d3 (diff)
downloadaports-6c7cdd83eb8533325dbc46b6899b87fc14c8cd2e.tar.bz2
aports-6c7cdd83eb8533325dbc46b6899b87fc14c8cd2e.tar.xz
community/radare2: move from testing
Diffstat (limited to 'community/radare2/APKBUILD')
-rw-r--r--community/radare2/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/radare2/APKBUILD b/community/radare2/APKBUILD
new file mode 100644
index 0000000000..a90d96a17f
--- /dev/null
+++ b/community/radare2/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: stef <l0ls0fo2i@ctrlc.hu>
+# Contributor: Jose-Luis Rivas <ghostbar@riseup.net>
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+pkgname=radare2
+pkgver=2.6.0
+pkgrel=1
+pkgdesc="An opensource, crossplatform reverse engineering framework"
+url="http://www.radare.org"
+arch="all !aarch64"
+license="GPL-3.0"
+options="!check" # upstream does not provide any working testsuite
+depends=""
+depends_dev=""
+makedepends="$depends_dev libzip-dev libressl-dev capstone-dev linux-headers"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg $pkgname-libs"
+source="$pkgname-$pkgver.tar.gz::https://github.com/radare/$pkgname/archive/${pkgver}.tar.gz
+ 0001-fix-for-build-with-syscapstone.patch
+ 0002-libc-respect-zip-deps.mk-for-zlib-libzip-10163.patch
+ 0003-make-don-t-dist-.-LIBVERSION-into-usr-lib-10164.patch
+ 0004-Add-with-libr-and-deprecate-with-nonpic-pic-merged-1.patch"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ [ "$CARCH" = "s390x" ] && _disable_debugger="--disable-debugger"
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ $_disable_debugger \
+ --with-syscapstone \
+ --with-openssl \
+ --with-syszip
+ make HAVE_LIBVERSION=1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="44e7d0c10e17b40d4d71af851cf462c159b03b3242dfccd786bd54d3cf9f92441084f26694166dd1385e84c00626f45dbe09d1fe713595721723c468ac47b01b radare2-2.6.0.tar.gz
+4a9c7ae1e3c692ba5a43f93142f8df6d9791ce580ff695e0dfe6587b07958eaf1cbb3e458a2331a1a05366778e0ed1a8db3808a395ecf8f9a9b55276755239b7 0001-fix-for-build-with-syscapstone.patch
+cdb37652ff6f987d7882d26e07d9a7e4f1116187551abf7b6f25c3a2e9b1ed5a2267e8d5351df470d8d1379940afdd56d669a92bdf47ad71c50a55641182c4a8 0002-libc-respect-zip-deps.mk-for-zlib-libzip-10163.patch
+f85861cb02e46200d70f18fbdfc1c176ef7c61dc33fb153d5d02a900e6f0b348e8d47e882637a28d6a48d6b90a55be9ad5b3007fd2794153ad4d47da47160b6e 0003-make-don-t-dist-.-LIBVERSION-into-usr-lib-10164.patch
+6498d50b83d3d4e769f3a0560e5a36818726f3e8907b119da68c040d7a94c340b5e319f285a038647bc5f1f5269b303520c60363ecf33fc2169d56f96878b6cc 0004-Add-with-libr-and-deprecate-with-nonpic-pic-merged-1.patch"