aboutsummaryrefslogtreecommitdiffstats
path: root/community/radare2
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-03-23 13:39:24 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2019-03-23 13:39:24 +0100
commit59cb4e09925e1e94432f681c0857a7e833ee9d87 (patch)
treeb868c13a19deb57f2e40ebe48735978de9064c4d /community/radare2
parent3ef59bcb772ecd823aadb53bee872a54a84580df (diff)
downloadaports-59cb4e09925e1e94432f681c0857a7e833ee9d87.tar.bz2
aports-59cb4e09925e1e94432f681c0857a7e833ee9d87.tar.xz
community/radare2: fix build on arm*
Diffstat (limited to 'community/radare2')
-rw-r--r--community/radare2/0001-Fix-musl-compatibility-ARM_VFPREGS_SIZE-is-defined-i.patch22
-rw-r--r--community/radare2/APKBUILD6
2 files changed, 26 insertions, 2 deletions
diff --git a/community/radare2/0001-Fix-musl-compatibility-ARM_VFPREGS_SIZE-is-defined-i.patch b/community/radare2/0001-Fix-musl-compatibility-ARM_VFPREGS_SIZE-is-defined-i.patch
new file mode 100644
index 0000000000..3dd7bbc66c
--- /dev/null
+++ b/community/radare2/0001-Fix-musl-compatibility-ARM_VFPREGS_SIZE-is-defined-i.patch
@@ -0,0 +1,22 @@
+From a3568f0098eab647f15ee5bc9411a50972886f12 Mon Sep 17 00:00:00 2001
+From: Johannes <johannes@jnbr.me>
+Date: Mon, 18 Mar 2019 22:37:35 +0100
+Subject: [PATCH] Fix musl compatibility - ARM_VFPREGS_SIZE is defined in
+ asm/ptrace.h (#13427)
+
+---
+ libr/debug/p/native/linux/linux_coredump.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libr/debug/p/native/linux/linux_coredump.c b/libr/debug/p/native/linux/linux_coredump.c
+index 64a9ec467..99bd6ea23 100644
+--- a/libr/debug/p/native/linux/linux_coredump.c
++++ b/libr/debug/p/native/linux/linux_coredump.c
+@@ -7,6 +7,7 @@
+ #if __x86_64__ || __i386__ || __arm__ || __arm64__
+ #include <sys/uio.h>
+ #include <sys/ptrace.h>
++#include <asm/ptrace.h>
+ #include "linux_coredump.h"
+
+ /* For compability */
diff --git a/community/radare2/APKBUILD b/community/radare2/APKBUILD
index 49330819f0..3ab3ce123d 100644
--- a/community/radare2/APKBUILD
+++ b/community/radare2/APKBUILD
@@ -16,7 +16,8 @@ depends_dev=""
makedepends="$depends_dev libzip-dev openssl-dev capstone-dev linux-headers"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg $pkgname-libs"
-source="$pkgname-$pkgver.tar.gz::https://github.com/radare/$pkgname/archive/${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/radare/$pkgname/archive/${pkgver}.tar.gz
+ 0001-Fix-musl-compatibility-ARM_VFPREGS_SIZE-is-defined-i.patch"
builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -41,4 +42,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="4db9d547b72b952babfd67c8cef2b94fdac9d6fd1194fb50b2ebab538d5bbda0bab4b704d5af64ef684ce9311634c8e04465906a1e7e706b211427054fe0721a radare2-3.3.0.tar.gz"
+sha512sums="4db9d547b72b952babfd67c8cef2b94fdac9d6fd1194fb50b2ebab538d5bbda0bab4b704d5af64ef684ce9311634c8e04465906a1e7e706b211427054fe0721a radare2-3.3.0.tar.gz
+8830129b765bfe9638398a314d05b1dee635c61e9d7d17084144263b65e0a667918da3a54466ddaf2a6f0f16dca4b83002db93f7a908e3f7e970d66e29bbe02f 0001-Fix-musl-compatibility-ARM_VFPREGS_SIZE-is-defined-i.patch"