aboutsummaryrefslogtreecommitdiffstats
path: root/community/rawtherapee
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-03-01 08:29:53 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-03-01 08:29:53 +0000
commit1257ebb0c5f280105a91d33fbd070ea6a6b5126c (patch)
treea9e5ba3812e4286957f8f7f4a18e337974fa71b7 /community/rawtherapee
parente4ce79df5a66f8592891286539d7e8b46140d4ad (diff)
downloadaports-1257ebb0c5f280105a91d33fbd070ea6a6b5126c.tar.bz2
aports-1257ebb0c5f280105a91d33fbd070ea6a6b5126c.tar.xz
community/rawtherapee: call default_prepare
Diffstat (limited to 'community/rawtherapee')
-rw-r--r--community/rawtherapee/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/rawtherapee/APKBUILD b/community/rawtherapee/APKBUILD
index 75db95d4bc..715a9bd41e 100644
--- a/community/rawtherapee/APKBUILD
+++ b/community/rawtherapee/APKBUILD
@@ -3,7 +3,7 @@
pkgname=rawtherapee
pkgver=5.4_rc2
_pkgver=${pkgver/_/-}
-pkgrel=1
+pkgrel=2
pkgdesc="RawTherapee is image processing software simular to Lightroom or Aperture"
url="http://rawtherapee.com"
arch="x86 x86_64 ppc64le"
@@ -14,14 +14,15 @@ makedepends="bzip2-dev exiv2-dev expat-dev fftw-dev glib-dev gtk+3.0-dev \
libiptcdata-dev libjpeg-turbo-dev lensfun-dev"
options="!check !strip"
subpackages="$pkgname-doc $pkgname-dbg"
-source="$pkgname-$pkgver.tar.xz::http://rawtherapee.com/shared/source/rawtherapee-$_pkgver.tar.xz"
+source="$pkgname-$pkgver.tar.xz::http://rawtherapee.com/shared/source/rawtherapee-${_pkgver}.tar.xz"
builddir="$srcdir"/$pkgname-$_pkgver
prepare() {
+ default_prepare
mkdir -p "$builddir"/build
- cd "$builddir"/build
export CXXFLAGS="$CXXFLAGS -std=c++11"
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cd "$builddir"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
}
build() {