aboutsummaryrefslogtreecommitdiffstats
path: root/community/rdfind/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-03-27 15:37:46 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-03-27 15:37:46 +0000
commiteece3b18c46334c59918a362fe1111b91554b504 (patch)
treea5844c46e48ac6a45bde58e47c4a4f0dad7c0e7c /community/rdfind/APKBUILD
parent39ab8b6d5c2d4943bc3a3715ed62e497b029b465 (diff)
downloadaports-eece3b18c46334c59918a362fe1111b91554b504.tar.bz2
aports-eece3b18c46334c59918a362fe1111b91554b504.tar.xz
community/rdfind: moved from testing
Diffstat (limited to 'community/rdfind/APKBUILD')
-rw-r--r--community/rdfind/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/rdfind/APKBUILD b/community/rdfind/APKBUILD
new file mode 100644
index 0000000000..f6b0e6c853
--- /dev/null
+++ b/community/rdfind/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=rdfind
+pkgver=1.3.5
+pkgrel=0
+pkgdesc="Redundant data find - a program that finds duplicate files"
+url="http://rdfind.pauldreik.se"
+arch="all"
+license="GPL2 "
+makedepends="nettle-dev"
+subpackages="$pkgname-doc"
+source="https://rdfind.pauldreik.se/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="${pkgdir}/" install
+}
+
+sha512sums="e546dd6022df3a6de606e57f184820c693cc5533b9e101a42dbca577d20e0ccd32b5f3cfb579bf94cf7ecbfb86fa0915427ab0c93ee9a94f66ffa54ff50ccfd1 rdfind-1.3.5.tar.gz"