aboutsummaryrefslogtreecommitdiffstats
path: root/community/re2/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-10-21 12:12:05 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-10-21 12:42:35 +0200
commit1c4f9c82a4414b94ea3366dbdd10d6bb95532032 (patch)
treeb11d6278f720e66d2240737387844a2790c2c965 /community/re2/APKBUILD
parentdf8b75ff568cc5c7ce311b9c48ea5ea76dd81572 (diff)
downloadaports-1c4f9c82a4414b94ea3366dbdd10d6bb95532032.tar.bz2
aports-1c4f9c82a4414b94ea3366dbdd10d6bb95532032.tar.xz
community/re2: rename from community/libre2
We usually don't prefix package names with `lib`.
Diffstat (limited to 'community/re2/APKBUILD')
-rw-r--r--community/re2/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/re2/APKBUILD b/community/re2/APKBUILD
new file mode 100644
index 0000000000..369c4d1637
--- /dev/null
+++ b/community/re2/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=re2
+pkgver=2018.10.01
+_pkgver=${pkgver//./-}
+pkgrel=0
+pkgdesc="Efficient, principled regular expression library"
+url="https://github.com/google/re2"
+arch="all"
+license="BSD-3-Clause"
+subpackages="$pkgname-dev $pkgname-doc"
+provides="libre2"
+source="https://github.com/google/$pkgname/archive/$_pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$_pkgver
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" prefix=/usr install
+ install -Dm644 LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="91e400856137d16c6319e310dab99b4baa74c0bcf634c97464fccdf4092ffc8e1d5ee2a6714b8114719e2dd92e962d5e970ce1b360a3644a8b395d8fb47431be 2018-10-01.tar.gz"