aboutsummaryrefslogtreecommitdiffstats
path: root/community/repmgr/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-20 02:30:24 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-20 02:30:53 +0200
commit07624af11c2ad2c6da1901025ac24e48a751c169 (patch)
tree9041d1c8ba54491c466b52ab0aab916ea5fce356 /community/repmgr/APKBUILD
parent6331c4ac4c98464f6f1c8c9dd27967e4966ffd13 (diff)
downloadaports-07624af11c2ad2c6da1901025ac24e48a751c169.tar.bz2
aports-07624af11c2ad2c6da1901025ac24e48a751c169.tar.xz
community/repmgr: move from testing
Diffstat (limited to 'community/repmgr/APKBUILD')
-rw-r--r--community/repmgr/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/community/repmgr/APKBUILD b/community/repmgr/APKBUILD
new file mode 100644
index 0000000000..b346d89a6c
--- /dev/null
+++ b/community/repmgr/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=repmgr
+pkgver=3.3.2
+pkgrel=2
+pkgdesc="Replication Manager for PostgreSQL"
+url="http://www.repmgr.org/"
+arch="all"
+license="GPL-3"
+depends="postgresql-client"
+makedepends="postgresql-dev"
+pkgusers="postgres"
+subpackages="$pkgname-doc $pkgname-daemon"
+source="$pkgname-$pkgver.tar.gz::https://github.com/2ndQuadrant/$pkgname/archive/v$pkgver.tar.gz
+ repmgr.conf.patch
+ repmgrd.initd"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!checkroot"
+
+build() {
+ cd "$builddir"
+ make USE_PGXS=1
+}
+
+check() {
+ cd "$builddir"
+ ./repmgr --version
+ ./repmgrd --version
+}
+
+package() {
+ cd "$builddir"
+
+ make USE_PGXS=1 DESTDIR="$pkgdir" install
+
+ install -D -m 640 -o postgres -g postgres \
+ repmgr.conf.sample "$pkgdir"/etc/repmgr.conf
+
+ cd "$pkgdir"
+
+ mkdir -p usr/share/doc/$pkgname
+ cp "$builddir"/*.md "$builddir"/docs/*.md usr/share/doc/$pkgname/
+}
+
+daemon() {
+ pkgdesc="A management and monitoring daemon for PostgreSQL Replication Manager"
+ depends="$pkgname"
+
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/repmgrd "$subpkgdir"/usr/bin/
+
+ install -D -m 755 "$srcdir"/repmgrd.initd "$subpkgdir"/etc/init.d/repmgrd
+}
+
+sha512sums="98fba8fc0d9074e496c66762dbec45734fe279f39c9c51adb3e66dca929ac37f66a609789c8c658545856fd81f5afc5b35f6b5e389e52bce8c04ce8c52acd8dd repmgr-3.3.2.tar.gz
+235a17d54ccce9e23b59919c0406fc3618f722e4f7559af6102c561668319a47beca7b70a9564432cb45bbbee091de9fc748935e7c771f1c84cfd40ab6e401a7 repmgr.conf.patch
+4ea90fc4b07898235eb3fd441a9f9857d2309e8c124e8e274ddcb44750db7aa2f59f03ac284ecba9150c1e17a8ae173cc5f493abfdc2b66cac3444802379c6e0 repmgrd.initd"