aboutsummaryrefslogtreecommitdiffstats
path: root/community/rethinkdb/APKBUILD
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2019-05-17 22:02:24 +0000
committerMike Sullivan <mksully22@gmail.com>2019-05-18 01:32:48 +0000
commit9c82030dc06d7a8c4f700cc3db2aa205616658b8 (patch)
tree95f11f075e0f7d5d895f02cd9e7084f34f6e05ce /community/rethinkdb/APKBUILD
parentf533e2ab49b71c30b1cd10907268076b489e43bc (diff)
downloadaports-9c82030dc06d7a8c4f700cc3db2aa205616658b8.tar.bz2
aports-9c82030dc06d7a8c4f700cc3db2aa205616658b8.tar.xz
community/rethinkdb: fix tribool errs with explicit cast and re=enable ppc64le and bump pkgrel to 10
Diffstat (limited to 'community/rethinkdb/APKBUILD')
-rw-r--r--community/rethinkdb/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/rethinkdb/APKBUILD b/community/rethinkdb/APKBUILD
index a2367413c0..48a76a1cc0 100644
--- a/community/rethinkdb/APKBUILD
+++ b/community/rethinkdb/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: Daniel Treadwell <daniel@djt.id.au>
pkgname=rethinkdb
pkgver=2.3.6
-pkgrel=9
+pkgrel=10
pkgdesc="Distributed powerful and scalable NoSQL database"
url="https://www.rethinkdb.com"
-arch="x86_64 s390x"
+arch="x86_64 ppc64le s390x"
license="Apache-2.0"
options="!check" # needs coffeescript
makedepends="bash python2 linux-headers bsd-compat-headers m4 paxmark
@@ -52,7 +52,7 @@ build() {
esac
export LDFLAGS="$LDFLAGS -lexecinfo"
- make CXXFLAGS="$CXXFLAGS -fno-delete-null-pointer-checks"
+ make CXXFLAGS="$CXXFLAGS -DBOOST_NO_CXX11_EXPLICIT_CONVERSION_OPERATORS -fno-delete-null-pointer-checks"
}
check() {