aboutsummaryrefslogtreecommitdiffstats
path: root/community/rhash/APKBUILD
diff options
context:
space:
mode:
authorPrzemyslaw Pawelczyk <przemoc@zoho.com>2016-11-21 14:38:30 +0100
committerTimo Teräs <timo.teras@iki.fi>2016-11-21 15:48:09 +0200
commit8b2a8b1a32ded529a034ba70033dcf90aaf3f194 (patch)
treefac7292ddda00bf05e072e744ecb4632345404a3 /community/rhash/APKBUILD
parenteff24145e92ae8c015cb86c2fd808311821f1d55 (diff)
downloadaports-8b2a8b1a32ded529a034ba70033dcf90aaf3f194.tar.bz2
aports-8b2a8b1a32ded529a034ba70033dcf90aaf3f194.tar.xz
community/rhash: moved from testing
Diffstat (limited to 'community/rhash/APKBUILD')
-rw-r--r--community/rhash/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/rhash/APKBUILD b/community/rhash/APKBUILD
new file mode 100644
index 0000000000..e90f6c7345
--- /dev/null
+++ b/community/rhash/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Przemyslaw Pawelczyk <przemoc@zoho.com>
+pkgname=rhash
+pkgver=1.3.4
+pkgrel=1
+pkgdesc="Utility for calculation and verification of hash sums and magnet links"
+url="http://rhash.anz.ru/"
+arch="all"
+license="custom"
+depends=
+depends_dev=""
+makedepends="$depends_dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-src.tar.gz
+ librhash-byte_order.h-Consult-also-compiler-s-predef.patch"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ make \
+ || return 1
+}
+
+package() {
+ cd "$builddir"
+ make install \
+ DESTDIR="$pkgdir" \
+ PREFIX=/usr \
+ || return 1
+}
+
+md5sums="0b51010604659e9e99f6307b053ba13b rhash-1.3.4.tar.gz
+59a1c0a0d04a7b4356a8b893dce7c266 librhash-byte_order.h-Consult-also-compiler-s-predef.patch"
+sha256sums="406662c4703bd4cb1caae26f32700951a5e12adf39f141d3f40e0b461b1e9e49 rhash-1.3.4.tar.gz
+19561529fdd2ccb1aaf54b0459962f969b7eadccd4119d8e4c94dadd8ed24589 librhash-byte_order.h-Consult-also-compiler-s-predef.patch"
+sha512sums="a78be309011798d5e55023eb93f898c10254a42270288fa5ec68ad446b5f3d001e8c6f893683e5171e3858c86d45ce2ce16eefde1173209e1925420c27a7ff7a rhash-1.3.4.tar.gz
+5d14156b42d41f976f605d0e07fe9ae5cf5cb2266f65e2ab09690b2bb992d348317c0e115c81015ff645eb25ff556e628d1ebc268ced816c5f192c0cc83e3ed1 librhash-byte_order.h-Consult-also-compiler-s-predef.patch"