aboutsummaryrefslogtreecommitdiffstats
path: root/community/ripgrep/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-19 04:37:38 +0100
committerAndré Klitzing <aklitzing@gmail.com>2020-01-19 11:59:27 +0100
commit7f5296fd3fb82d32e9d009b540136954fd41b808 (patch)
tree3a0007f9fe7eee339da38f41c429f50173f57478 /community/ripgrep/APKBUILD
parentf583202be0519dc703d0cecf17d7003c5c99fdb8 (diff)
downloadaports-7f5296fd3fb82d32e9d009b540136954fd41b808.tar.bz2
aports-7f5296fd3fb82d32e9d009b540136954fd41b808.tar.xz
community/ripgrep: add missing checkdepends on xz
Diffstat (limited to 'community/ripgrep/APKBUILD')
-rw-r--r--community/ripgrep/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/ripgrep/APKBUILD b/community/ripgrep/APKBUILD
index a3a83fa3c0..2fc5fb7986 100644
--- a/community/ripgrep/APKBUILD
+++ b/community/ripgrep/APKBUILD
@@ -8,11 +8,12 @@ url="https://github.com/BurntSushi/ripgrep"
arch="x86_64 armhf armv7" # limited by cargo pkg
license="MIT public-domain"
makedepends="cargo asciidoc pcre2-dev"
+checkdepends="xz"
subpackages="$pkgname-doc
$pkgname-bash-completion:bashcomp:noarch
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-fish-completion:fishcomp:noarch"
-source="$pkgname-$pkgver.tar.gz::https://github.com/BurntSushi/$pkgname/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/BurntSushi/ripgrep/archive/$pkgver.tar.gz"
build() {
cargo build --release --features 'pcre2'