aboutsummaryrefslogtreecommitdiffstats
path: root/community/ripmime/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-11-02 09:44:23 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2017-11-02 23:49:19 +0100
commit414b1d85dc88bd568767f07cae0d36dbcfd95d7e (patch)
tree9188cfeb6b1b4c457a6b90439bcf3e1d70aa952e /community/ripmime/APKBUILD
parentb2578af8bd83ad9ce56f6ed5cfc9724b4e058d39 (diff)
downloadaports-414b1d85dc88bd568767f07cae0d36dbcfd95d7e.tar.bz2
aports-414b1d85dc88bd568767f07cae0d36dbcfd95d7e.tar.xz
testing/ripmime: move to community
Diffstat (limited to 'community/ripmime/APKBUILD')
-rw-r--r--community/ripmime/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/ripmime/APKBUILD b/community/ripmime/APKBUILD
new file mode 100644
index 0000000000..589be6bad8
--- /dev/null
+++ b/community/ripmime/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
+pkgname=ripmime
+pkgver=1.4.0.10
+pkgrel=0
+pkgdesc="Tool to extract the attached files out of a MIME package"
+url="http://www.pldaniels.com/ripmime/"
+arch="all"
+license="BSD-3-Clause"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://www.pldaniels.com/ripmime/ripmime-$pkgver.tar.gz
+ ripmime-1.4.0.10-makefile.patch
+ "
+builddir="$srcdir/ripmime-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ msg "Running testsuites..."
+ "$builddir"/$pkgname --version > /dev/null
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e1eae0ad93a50e19ab1966a6f95ae8704e59bc081f89da1e2894a3bb2a2eaea8b0fc4709ec29d126053517d56c72d6ee2a77f0d8e3fb5f223255d45e0b515ab0 ripmime-1.4.0.10.tar.gz
+a400e446a8de8ffa3c167155a601a5291b795e9875f51910c34b2f037cf5bf4cefb7e344bc3099878a36aa009d97e84c170dc6a5180721b4a82b7a1484a9c11d ripmime-1.4.0.10-makefile.patch"