aboutsummaryrefslogtreecommitdiffstats
path: root/community/rippled
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-03-16 01:39:04 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-17 19:29:08 +0000
commite303d96228db5c870cafed7ea0c60a16fe584067 (patch)
tree36057b0f9a5cc03d01776fbbe9a9d92eda48be48 /community/rippled
parent57747e158192e9cfa055f4a6dc9b9b218327d52c (diff)
downloadaports-e303d96228db5c870cafed7ea0c60a16fe584067.tar.bz2
aports-e303d96228db5c870cafed7ea0c60a16fe584067.tar.xz
community/rippled: upgrade to 1.2.2
Diffstat (limited to 'community/rippled')
-rw-r--r--community/rippled/APKBUILD10
-rw-r--r--community/rippled/fix-tests.patch35
2 files changed, 3 insertions, 42 deletions
diff --git a/community/rippled/APKBUILD b/community/rippled/APKBUILD
index 35a167b063..d6c6adcce2 100644
--- a/community/rippled/APKBUILD
+++ b/community/rippled/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=rippled
-pkgver=1.1.2
+pkgver=1.2.2
pkgrel=0
pkgdesc="Blockchain daemon implementing the Ripple Consensus Ledger"
url="https://ripple.com/"
@@ -10,15 +10,13 @@ license="ISC"
makedepends="cmake openssl-dev boost-dev protobuf-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ripple/$pkgname/archive/$pkgver.tar.gz
- 8fc6a8175b266adaf02b2662e174869e3a55b8cf.patch::https://github.com/ripple/rippled/commit/8fc6a8175b266adaf02b2662e174869e3a55b8cf.patch
- fix-tests.patch
"
builddir="$srcdir/"$pkgname-$pkgver
build() {
cd "$builddir"
mkdir build && cd build
- cmake .. -Dstatic=OFF -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=release
+ cmake .. -Dstatic=OFF -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
cmake --build .
}
@@ -35,6 +33,4 @@ package() {
install -D -m644 cfg/validators-example.txt "${pkgdir}/etc/$pkgname/validators.txt"
}
-sha512sums="78fc36e442d1fa6b9709d8de5ddcaf4a0e44867e50e27f3fa7556f39b777f415a34c61ea9247a225d48c3b2bbd971d03617a92cc614c833070ad75692369b59f rippled-1.1.2.tar.gz
-b1882e45d79a0a375f8bdfa5b2154cf027a7af23778b85796c8d89f08fc64d39ce231630950f646e5a0e88a59c634bd538b042f33141f90ef809cc9d76011a98 8fc6a8175b266adaf02b2662e174869e3a55b8cf.patch
-cc038e87adf97e4dcd5ea60ff6f45fc988177358b02c116134b65b08dd69a0079f38b56e0dc11c4faaeadc2d707ba5eeeb1a5869dbe95a0cf616599926566d58 fix-tests.patch"
+sha512sums="20ce3f1e5307463c386f4e29c57826bdbc49c49b4b0569a8aa309e384943c28b9ccc7ef450a0ef299ad03fa53427fff73e4d0afb7000ee01d11824a4cb1ddb74 rippled-1.2.2.tar.gz"
diff --git a/community/rippled/fix-tests.patch b/community/rippled/fix-tests.patch
deleted file mode 100644
index 8e11f002f3..0000000000
--- a/community/rippled/fix-tests.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From ab6163e989e93a67afb13285539fd89e60a1c11a Mon Sep 17 00:00:00 2001
-From: Mike Ellery <mellery451@gmail.com>
-Date: Thu, 13 Sep 2018 08:25:02 -0700
-Subject: [PATCH] Remove test sensitivity to error text from OpenSSL
-
----
- src/test/beast/beast_asio_error_test.cpp | 15 ++++++++-------
- 1 file changed, 8 insertions(+), 7 deletions(-)
-
-diff --git a/src/test/beast/beast_asio_error_test.cpp b/src/test/beast/beast_asio_error_test.cpp
-index 4a3400ea70..5aeb925cba 100644
---- a/src/test/beast/beast_asio_error_test.cpp
-+++ b/src/test/beast/beast_asio_error_test.cpp
-@@ -32,13 +32,14 @@ class error_test : public unit_test::suite
- boost::system::error_code ec =
- boost::system::error_code (335544539,
- boost::asio::error::get_ssl_category ());
-- std::string const s = beast::error_message_with_ssl(ec);
--
--#ifdef SSL_R_SHORT_READ
-- BEAST_EXPECT(s == " (20,0,219) error:140000DB:SSL routines:SSL routines:short read");
--#else
-- BEAST_EXPECT(s == " (20,0,219) error:140000DB:SSL routines:SSL routines:reason(219)");
--#endif
-+ std::string s = beast::error_message_with_ssl(ec);
-+ // strip away last part of the error message since
-+ // it can vary with openssl versions and/or compile
-+ // flags
-+ auto const lastColon = s.find_last_of(':');
-+ if (lastColon != s.npos)
-+ s = s.substr(0, lastColon);
-+ BEAST_EXPECT(s == " (20,0,219) error:140000DB:SSL routines:SSL routines");
- }
- }
- };