aboutsummaryrefslogtreecommitdiffstats
path: root/community/rpm
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-25 07:47:35 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-25 07:55:48 +0000
commit3f23a4137b928c5ea363afd39af52af49eacb5ce (patch)
tree1b49ce93c4cef47571c7067d477d2f0a97f949ce /community/rpm
parent9994bb8b5c328ba14a44119d774fba884c74faaa (diff)
downloadaports-3f23a4137b928c5ea363afd39af52af49eacb5ce.tar.bz2
aports-3f23a4137b928c5ea363afd39af52af49eacb5ce.tar.xz
community/rpm: upgrade to 4.12.0.1
Diffstat (limited to 'community/rpm')
-rw-r--r--community/rpm/APKBUILD54
-rw-r--r--community/rpm/rpm-uclibc.patch45
2 files changed, 99 insertions, 0 deletions
diff --git a/community/rpm/APKBUILD b/community/rpm/APKBUILD
new file mode 100644
index 0000000000..f72c48e931
--- /dev/null
+++ b/community/rpm/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=rpm
+pkgver=4.12.0.1
+pkgrel=0
+pkgdesc="The RPM package manager"
+url="http://www.rpm.org/"
+arch="all"
+license="GPL2 LGPL2+"
+depends=""
+depends_dev="nspr-dev nss-dev db-dev lua-dev zlib-dev bzip2-dev xz-dev
+ libelf-dev file-dev popt-dev libcap-dev acl-dev libarchive-dev
+ binutils-dev"
+makedepends="$depends_dev graphviz gettext-dev python2-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py-rpm:py_rpm"
+source="http://rpm.org/releases/rpm-4.12.x/$pkgname-$pkgver.tar.bz2
+ rpm-uclibc.patch"
+
+builddir="$srcdir"/rpm-$pkgver
+
+build() {
+ cd "$builddir"
+ _EXT_CPPFLAGS="-I/usr/include/nspr -I/usr/include/nss" \
+ CFLAGS="$CFLAGS $_EXT_CPPFLAGS" CPPFLAGS="$CPPFLAGS $_EXT_CPPFLAGS" \
+ LIBS="$LIBS -lintl" \
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-external-db \
+ --with-cap --with-acl \
+ --enable-python \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+py_rpm() {
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib || return 1
+}
+
+md5sums="c06a691765252d2b381a7942a9669856 rpm-4.12.0.1.tar.bz2
+528cdfc96ebfe8db3e389abdcf024d94 rpm-uclibc.patch"
+sha256sums="77ddd228fc332193c874aa0b424f41db1ff8b7edbb6a338703ef747851f50229 rpm-4.12.0.1.tar.bz2
+e963102ba11f83b691ad27ca7df9283524710a8fbd458e85e6ac84f3413778e9 rpm-uclibc.patch"
+sha512sums="ae751b04cec2463f1f259aec4b4750fca1e4cef6144b7e612d0c94f7b6a2864ed119547568f6acebb7fefddb7b040b6021c1f32cf465963db0b627f524c5760f rpm-4.12.0.1.tar.bz2
+7a5796716b0f53e0c7fde5d7f42bd767eb2dd03fda03179779b7085e7f0dfc72a1c246621458d3bbe6227a5d59074b3f29147eea34d889a700b3ff47b799c2ce rpm-uclibc.patch"
diff --git a/community/rpm/rpm-uclibc.patch b/community/rpm/rpm-uclibc.patch
new file mode 100644
index 0000000000..12636f0fc9
--- /dev/null
+++ b/community/rpm/rpm-uclibc.patch
@@ -0,0 +1,45 @@
+diff -rupN a/misc/fts.c b/misc/fts.c
+--- a/misc/fts.c 2012-11-07 13:55:24.000000000 +0100
++++ b/misc/fts.c 2014-03-06 08:15:37.983514119 +0100
+@@ -42,6 +42,11 @@ static char sccsid[] = "@(#)fts.c 8.6 (B
+ #include <string.h>
+ #include <unistd.h>
+ #else
++#include "system.h"
++#include <stdlib.h>
++#include <string.h>
++#include <errno.h>
++#include "misc/fts.h"
+ #if defined(hpux)
+ # define _INCLUDE_POSIX_SOURCE
+ # define __errno_location() (&errno)
+@@ -61,11 +66,10 @@ static char sccsid[] = "@(#)fts.c 8.6 (B
+ # define _STAT_VER 0
+ # define __fxstat64(_stat_ver, _fd, _sbp) fstat64((_fd), (_sbp))
+ #endif
+-#include "system.h"
+-#include <stdlib.h>
+-#include <string.h>
+-#include <errno.h>
+-#include "misc/fts.h"
++#if !defined(__GLIBC__) || defined(__UCLIBC__)
++# define _STAT_VER 0
++# define __fxstat64(_stat_ver, _fd, _sbp) fstat64((_fd), (_sbp))
++#endif
+ # define __set_errno(val) (*__errno_location ()) = (val)
+ # define __open open
+ # define __close close
+diff -rupN a/misc/fts.h b/misc/fts.h
+--- a/misc/fts.h 2012-11-07 13:55:24.000000000 +0100
++++ b/misc/fts.h 2014-03-06 08:17:10.426850180 +0100
+@@ -61,6 +61,10 @@
+ # define _D_EXACT_NAMLEN(d) (strlen((d)->d_name))
+ #endif
+
++#if !defined(_D_EXACT_NAMLEN)
++# define _D_EXACT_NAMLEN(d) (strlen((d)->d_name))
++#endif
++
+ #endif
+
+ #include <sys/types.h>