aboutsummaryrefslogtreecommitdiffstats
path: root/community/rpm
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-11 02:41:11 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-11 02:41:19 +0000
commit6d0df83f62e2bbb15cad18e0469f8dd2ae6d3c8b (patch)
tree6e2b49fd8e018f3e9347829dd554b10d1eab9bcc /community/rpm
parent44dec89dacd3f73a981d9354de1997dca63d86e5 (diff)
downloadaports-6d0df83f62e2bbb15cad18e0469f8dd2ae6d3c8b.tar.bz2
aports-6d0df83f62e2bbb15cad18e0469f8dd2ae6d3c8b.tar.xz
community/rpm: upgrade to 4.13.0.2 and modernize
Diffstat (limited to 'community/rpm')
-rw-r--r--community/rpm/APKBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/community/rpm/APKBUILD b/community/rpm/APKBUILD
index 615c4f10a6..376208a6b2 100644
--- a/community/rpm/APKBUILD
+++ b/community/rpm/APKBUILD
@@ -1,22 +1,20 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=rpm
-pkgver=4.13.0
-pkgrel=1
+pkgver=4.13.0.2
+pkgrel=0
pkgdesc="The RPM package manager"
url="http://www.rpm.org/"
arch="all"
license="GPL2 LGPL2+"
-depends=""
depends_dev="nspr-dev nss-dev db-dev lua-dev zlib-dev bzip2-dev xz-dev
libelf-dev file-dev popt-dev libcap-dev acl-dev libarchive-dev
binutils-dev"
makedepends="$depends_dev graphviz gettext-dev python2-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py-rpm:py_rpm"
source="http://ftp.rpm.org/releases/rpm-4.13.x/$pkgname-$pkgver.tar.bz2"
-builddir="$srcdir"/rpm-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -30,21 +28,18 @@ build() {
--localstatedir=/var \
--with-external-db \
--with-cap --with-acl \
- --enable-python \
- || return 1
- make || return 1
+ --enable-python
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
py_rpm() {
mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib || return 1
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib
}
-md5sums="f64e70c7548911da51a11651a789e30e rpm-4.13.0.tar.bz2"
-sha256sums="221166b61584721a8ca979d7d8576078a5dadaf09a44208f69cc1b353240ba1b rpm-4.13.0.tar.bz2"
-sha512sums="d13d9170d5aba93698acfaa88a8ef4cddc9dc9d57aff88fa6947b23efcb11b51d4953f8ed2804b2b052fc6c7d9a95d2f5da599b9c17490c643bf8eff7b68f6e9 rpm-4.13.0.tar.bz2"
+sha512sums="9b15acb2684bc963f7164763568615b2484478eaec0cea8b3bd4ddb94b862a70b2f4b4ab432d896e5885c9a191c4d7d2ede573a5feabc8ec290108956a8a4917 rpm-4.13.0.2.tar.bz2"