aboutsummaryrefslogtreecommitdiffstats
path: root/community/rspamd
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-24 00:33:47 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-25 02:52:12 +0200
commitb07adc22d07e4adb8033da41b7827a0d17b4a429 (patch)
treef9f15a4581c9032810a234d5eaa795a186aa861d /community/rspamd
parent0a69bbf3fafe505f2d2baf538076d6862a3f35e1 (diff)
downloadaports-b07adc22d07e4adb8033da41b7827a0d17b4a429.tar.bz2
aports-b07adc22d07e4adb8033da41b7827a0d17b4a429.tar.xz
community/rspamd: replace sed with patch file
To avoid silent breakages.
Diffstat (limited to 'community/rspamd')
-rw-r--r--community/rspamd/APKBUILD10
-rw-r--r--community/rspamd/default-configs.patch22
2 files changed, 23 insertions, 9 deletions
diff --git a/community/rspamd/APKBUILD b/community/rspamd/APKBUILD
index bdeeb2ed68..6dd7f65ede 100644
--- a/community/rspamd/APKBUILD
+++ b/community/rspamd/APKBUILD
@@ -26,17 +26,9 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/vstakhov/$pkgname/archive/$p
$pkgname.confd
cmakelists.patch
conf-split-workers.patch
+ default-configs.patch
"
-prepare() {
- default_prepare
-
- cd "$builddir"
- sed -ri -e 's~DBDIR(/rspamd.sock)~RUNDIR\1~' \
- -e 's~rspamd_dynamic~dynamic~' \
- conf/options.inc
-}
-
build() {
cd "$builddir"
cmake CMakeLists.txt \
diff --git a/community/rspamd/default-configs.patch b/community/rspamd/default-configs.patch
new file mode 100644
index 0000000000..776444f9cb
--- /dev/null
+++ b/community/rspamd/default-configs.patch
@@ -0,0 +1,22 @@
+Distro-specific adjustments of the default configs.
+
+--- a/conf/options.inc
++++ b/conf/options.inc
+@@ -8,7 +8,7 @@
+ map_watch_interval = 5min;
+ # Multiplier for watch interval for files
+ map_file_watch_multiplier = 0.1;
+-dynamic_conf = "$DBDIR/rspamd_dynamic";
++dynamic_conf = "$DBDIR/dynamic";
+ history_file = "$DBDIR/rspamd.history";
+ check_all_filters = false;
+ dns {
+@@ -25,7 +25,7 @@
+ "X-MimeOLE",
+ ];
+
+-control_socket = "$DBDIR/rspamd.sock mode=0600";
++control_socket = "$RUNDIR/rspamd.sock mode=0600";
+ history_rows = 200;
+ explicit_modules = ["settings", "bayes_expiry"];
+