aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-ffi/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-07-15 23:58:19 +0200
committerJakub Jirutka <jakub@jirutka.cz>2019-07-16 00:09:55 +0200
commit533116529132daeaa24442d9f435c7f8aea4c8ed (patch)
tree9e76dc846f964c415f009f600280678b96f3e86a /community/ruby-ffi/APKBUILD
parent4c3e05a6c693038c19c8bb45fc8807af9f17cbb8 (diff)
downloadaports-533116529132daeaa24442d9f435c7f8aea4c8ed.tar.bz2
aports-533116529132daeaa24442d9f435c7f8aea4c8ed.tar.xz
community/ruby-ffi: install test dependencies from aports
Diffstat (limited to 'community/ruby-ffi/APKBUILD')
-rw-r--r--community/ruby-ffi/APKBUILD13
1 files changed, 2 insertions, 11 deletions
diff --git a/community/ruby-ffi/APKBUILD b/community/ruby-ffi/APKBUILD
index 1e6f4bfdf8..d950d5b7f4 100644
--- a/community/ruby-ffi/APKBUILD
+++ b/community/ruby-ffi/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Ruby FFI library"
url="https://github.com/ffi/ffi"
arch="all"
license="BSD-3-Clause"
-checkdepends="ruby-fiddle"
+checkdepends="ruby-fiddle ruby-rspec"
makedepends="libffi-dev ruby ruby-dev"
install="$pkgname.post-install"
source="$pkgname-$pkgver.tar.gz::https://github.com/ffi/$_gemname/archive/$pkgver.tar.gz
@@ -26,16 +26,7 @@ build() {
}
check() {
- # Install missing development dependencies needed and used only for running
- # tests. We can't install them easily with bundler, because there's
- # no way how to force it to NOT update already satisifed dependencies.
- # We can't install them directly with gem either, because there's no
- # way how to force it to instally only dependencies, not the gem itself.
- local dev_deps=$(gem install --explain --development --minimal-deps $_gemname-$pkgver.gem \
- | head -n -1 | sed -En 's/-([^-]+)$/:\1/p')
- gem install --instal-dir=.gem --conservative $dev_deps
-
- GEM_PATH='dist:.gem' .gem/bin/rspec
+ GEM_PATH='dist:.gem' rspec
}
package() {