aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-rake-compiler
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-27 04:30:31 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-02 15:53:21 +0000
commit4b1f889340c52c2e1af47b94fe0102c4b87beebf (patch)
tree1e5f4e67226a81051068534297648c75ebb552e8 /community/ruby-rake-compiler
parent25cf16ff97192395193628733d81a6d5fbcb874a (diff)
downloadaports-4b1f889340c52c2e1af47b94fe0102c4b87beebf.tar.bz2
aports-4b1f889340c52c2e1af47b94fe0102c4b87beebf.tar.xz
community/ruby-rake-compiler: upgrade to 1.0.8
Closes !198
Diffstat (limited to 'community/ruby-rake-compiler')
-rw-r--r--community/ruby-rake-compiler/APKBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/community/ruby-rake-compiler/APKBUILD b/community/ruby-rake-compiler/APKBUILD
index cccce756cb..58a92d2da2 100644
--- a/community/ruby-rake-compiler/APKBUILD
+++ b/community/ruby-rake-compiler/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ruby-rake-compiler
_gemname=${pkgname#ruby-}
-pkgver=1.0.7
-pkgrel=1
+pkgver=1.0.8
+pkgrel=0
pkgdesc="Provide a standard and simplified way to build and package Ruby extensions"
url="https://github.com/rake-compiler/rake-compiler"
arch="noarch"
@@ -15,20 +15,16 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/rake-compiler/$_gemname/arch
builddir="$srcdir/$_gemname-$pkgver"
build() {
- cd "$builddir"
gem build $_gemname.gemspec
}
check() {
- cd "$builddir"
rspec spec
}
package() {
local gemdir="$pkgdir/$(ruby -e 'puts Gem.default_dir')"
- cd "$builddir"
-
gem install --local \
--install-dir "$gemdir" \
--bindir "$pkgdir/usr/bin" \
@@ -42,5 +38,5 @@ package() {
rm -r cache build_info doc
}
-sha512sums="fa901f5cc48891f07bd8d9a27cf4e745e87d5a667dbee0c9f4b43f9564fdfe3067b9c658f10ea8bcacd32ea7320a542ef0fca9373147057472f5572a4a4c5268 ruby-rake-compiler-1.0.7.tar.gz
+sha512sums="30b753d45a1180e034b520ad6385f2799098f0916d55e8b4729f5e3a29dabc1acfa292475edfb384c7809543e1c3e428e28db1bacb5383deb9f4bb31b18d6fe5 ruby-rake-compiler-1.0.8.tar.gz
e68672541d62898bc72fb7e40f16bc75ed1d46eabedd18da60a6f0673d67bf63d990e191fb41d6034e3f6361662807030cbd8f0c817223a5d03c46a3a664f855 gemfile-remove-unwanted-files.patch"