aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-rspec
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-25 23:50:25 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-25 23:50:25 +0100
commit3297d634f4371b930eba14293bc829b9c4a5150e (patch)
tree2198f7bd88fa2d064f4a92746f7f46fdd065fb03 /community/ruby-rspec
parent94f91d25906569a622b1bdbd61766449230daa27 (diff)
downloadaports-3297d634f4371b930eba14293bc829b9c4a5150e.tar.bz2
aports-3297d634f4371b930eba14293bc829b9c4a5150e.tar.xz
community/ruby-rspec*: move from testing
Diffstat (limited to 'community/ruby-rspec')
-rw-r--r--community/ruby-rspec/APKBUILD43
-rw-r--r--community/ruby-rspec/gemspec.patch14
2 files changed, 57 insertions, 0 deletions
diff --git a/community/ruby-rspec/APKBUILD b/community/ruby-rspec/APKBUILD
new file mode 100644
index 0000000000..ef343fbfe8
--- /dev/null
+++ b/community/ruby-rspec/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ruby-rspec
+_gemname=${pkgname#ruby-}
+pkgver=3.7.0
+pkgrel=0
+pkgdesc="Behaviour Driven Development for Ruby"
+url="http://rspec.info/"
+arch="noarch"
+license="MIT"
+depends="ruby
+ ruby-rspec-core>=${pkgver%.*}.0
+ ruby-rspec-expectations>=${pkgver%.*}.0
+ ruby-rspec-mocks>=${pkgver%.*}.0"
+options="!check" # no tests provided
+source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
+ gemspec.patch"
+builddir="$srcdir/$_gemname-$pkgver"
+
+build() {
+ cd "$builddir"
+ gem build $_gemname.gemspec
+}
+
+package() {
+ local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+
+ cd "$builddir"
+ gem install --local \
+ --install-dir "$gemdir" \
+ --ignore-dependencies \
+ --no-document \
+ --verbose \
+ $_gemname
+
+ # Clean-up...
+ rm -r "$gemdir"/cache \
+ "$gemdir"/build_info \
+ "$gemdir"/doc
+}
+
+sha512sums="7bfb70f368a718077365fb81849905705d5268bae9463447466c910220d4812752abc057f7da2822eb5593e9d5ac2764ff3e05faafb7feb4d2a140334e23e848 ruby-rspec-3.7.0.tar.gz
+f554eef881574e68532dd6c9edeb6b8ad172ac707f7518134378e1099a40ada959c6c770514aab13a6345343113594208be0e42044803c0c2cde3adde00c5520 gemspec.patch"
diff --git a/community/ruby-rspec/gemspec.patch b/community/ruby-rspec/gemspec.patch
new file mode 100644
index 0000000000..1bd3937c3a
--- /dev/null
+++ b/community/ruby-rspec/gemspec.patch
@@ -0,0 +1,14 @@
+--- a/rspec.gemspec
++++ b/rspec.gemspec
+@@ -14,10 +14,7 @@
+ s.summary = "rspec-#{RSpec::Version::STRING}"
+ s.description = "BDD for Ruby"
+
+- s.files = `git ls-files -- lib/*`.split("\n")
+- s.files += ["LICENSE.md"]
+- s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
+- s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
++ s.files = Dir["lib/**/*"]
+ s.extra_rdoc_files = [ "README.md" ]
+ s.rdoc_options = ["--charset=UTF-8"]
+ s.require_path = "lib"