aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby2.2
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-29 14:26:42 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-29 14:26:42 +0200
commitc51abd40826499b7b04eb25d8f170fddc5bb5b79 (patch)
tree478eb11c9e35a012b5d4d85a96b5c68738ba865a /community/ruby2.2
parent014ce40433767fbc5c6a4fc8c266bfcf6fce6d18 (diff)
downloadaports-c51abd40826499b7b04eb25d8f170fddc5bb5b79.tar.bz2
aports-c51abd40826499b7b04eb25d8f170fddc5bb5b79.tar.xz
community/ruby2.2: move all *.gemspec to subpkg, fix error in _mvgem
Diffstat (limited to 'community/ruby2.2')
-rw-r--r--community/ruby2.2/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/ruby2.2/APKBUILD b/community/ruby2.2/APKBUILD
index 7b66978cd8..ea869f9ee3 100644
--- a/community/ruby2.2/APKBUILD
+++ b/community/ruby2.2/APKBUILD
@@ -6,7 +6,7 @@ _majorver=${pkgname#ruby}
pkgver="$_majorver.5"
_pkgver=${pkgver/_/-}
_abiver="$_majorver.0"
-pkgrel=0
+pkgrel=1
pkgdesc="An object-oriented language for quick and easy programming"
url="http://www.ruby-lang.org/en/"
arch="all"
@@ -175,8 +175,9 @@ _mvgem() {
./$_rubydir/${1} \
./$_rubydir/$_chost/${1} \
./$_gemdir/gems/${1}-* \
+ ./$_gemdir/specifications/${1}-* \
./$_gemdir/specifications/default/${1}-* ; do
- [ -e "$pkgdir/$path" ] && _mv "$path"
+ [ ! -e "$pkgdir/$path" ] || _mv "$path"
done
}