aboutsummaryrefslogtreecommitdiffstats
path: root/community/rust
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-10-03 15:17:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-10-04 14:16:35 +0000
commit351e828ddb447e649acfc38775596d290f92cb05 (patch)
tree70bd52cd704c1bcfd08d46617698affde489cdd4 /community/rust
parentbc331fde131b1e62e12a08776ca56e14411abc64 (diff)
downloadaports-351e828ddb447e649acfc38775596d290f92cb05.tar.bz2
aports-351e828ddb447e649acfc38775596d290f92cb05.tar.xz
community/rust: build fix
we need llvm-libunwind-static
Diffstat (limited to 'community/rust')
-rw-r--r--community/rust/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index 0cfd561ad0..69bd76ce16 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -16,7 +16,8 @@ license="Apache-2.0 AND MIT"
# gcc is needed at runtime just for linking. Someday rustc might invoke
# the linker directly, and then we'll only need binutils.
# See: https://github.com/rust-lang/rust/issues/11937
-depends="$pkgname-stdlib=$pkgver-r$pkgrel gcc llvm-libunwind-dev musl-dev"
+depends="$pkgname-stdlib=$pkgver-r$pkgrel gcc llvm-libunwind-dev
+ llvm-libunwind-static musl-dev"
# * Rust is self-hosted, so you need rustc (and cargo) to build rustc...
# The last revision of this abuild that does not depend on itself (uses