aboutsummaryrefslogtreecommitdiffstats
path: root/community/rutorrent
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-11-09 12:49:18 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-11-09 12:49:18 +0000
commit0da19cce01c8b0cd59063889fd2fb5c7fa107012 (patch)
tree657c70dc3eefbc3aa71864628e83c4d5987089ef /community/rutorrent
parentea788450bb7bf363bf8730f5e782ca805a3c5fe5 (diff)
downloadaports-0da19cce01c8b0cd59063889fd2fb5c7fa107012.tar.bz2
aports-0da19cce01c8b0cd59063889fd2fb5c7fa107012.tar.xz
community/rutorrent: fix tab indent and modernize APKBUILD
Diffstat (limited to 'community/rutorrent')
-rw-r--r--community/rutorrent/APKBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/community/rutorrent/APKBUILD b/community/rutorrent/APKBUILD
index d5f9fc91d9..51e79ead25 100644
--- a/community/rutorrent/APKBUILD
+++ b/community/rutorrent/APKBUILD
@@ -9,29 +9,29 @@ url="https://github.com/Novik/ruTorrent"
arch="noarch"
license="GPL"
depends="php7 curl"
+options="!check" # no test available
# we need to user gnu tar since the permissions on files in tar archive are
# bad
makedepends="tar"
pkggroups="rutorrent"
install="$pkgname.pre-install $pkgname.post-install"
-subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/Novik/$_pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
+ cd "$builddir"
chmod -R u+w "$builddir"
}
package() {
- cd "$builddir"
- install -d $pkgdir/usr/share/webapps/$pkgname
- install -d $pkgdir/var/www/localhost/htdocs/
- cp -r * $pkgdir/usr/share/webapps/$pkgname
- chgrp -R rutorrent $pkgdir/usr/share/webapps/$pkgname/share
- chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/settings
- chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/torrents
- chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/users
+ cd "$builddir"
+ install -d $pkgdir/usr/share/webapps/$pkgname
+ install -d $pkgdir/var/www/localhost/htdocs/
+ cp -r * $pkgdir/usr/share/webapps/$pkgname
+ chgrp -R rutorrent $pkgdir/usr/share/webapps/$pkgname/share
+ chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/settings
+ chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/torrents
+ chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/users
}
sha512sums="ea3dfa74234a1eafcbc9e71d6c6d953a46fdf8e189237b8df0ec58cf46ac30404f7a15bb783ec7567ab6f28daa3987ee219039dd360e3c48d16aea244263c9b6 rutorrent-3.8.tar.gz"