aboutsummaryrefslogtreecommitdiffstats
path: root/community/safekeep
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2019-03-19 18:58:41 +0100
committerHenrik Riomar <henrik.riomar@gmail.com>2019-03-20 19:08:22 +0100
commit677d33d918d924b4180661daa1184ead7aa8073b (patch)
tree296813249f55d7dafe6e8020d3d4686c6a776c87 /community/safekeep
parent333ed82593af01cf2a74180b9214c59528fb1e11 (diff)
downloadaports-677d33d918d924b4180661daa1184ead7aa8073b.tar.bz2
aports-677d33d918d924b4180661daa1184ead7aa8073b.tar.xz
community/safekeep: upgrade to 1.5.0
Switch from Python2 to Python3 Clarify license
Diffstat (limited to 'community/safekeep')
-rw-r--r--community/safekeep/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/safekeep/APKBUILD b/community/safekeep/APKBUILD
index ec3ef8847f..d080437bb9 100644
--- a/community/safekeep/APKBUILD
+++ b/community/safekeep/APKBUILD
@@ -1,13 +1,13 @@
# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
pkgname=safekeep
-pkgver=1.4.5
+pkgver=1.5.0
pkgrel=0
pkgdesc="SafeKeep backup system"
url="https://github.com/dimipaun/safekeep"
arch="noarch"
-license="GPL-2.0"
-depends="openssh-client python2 rdiff-backup util-linux"
+license="GPL-2.0-or-later"
+depends="openssh-client python3 rdiff-backup util-linux"
makedepends="asciidoc libxml2-utils xmlto"
install="$pkgname-server.post-install"
subpackages="$pkgname-doc $pkgname-client $pkgname-server"
@@ -29,14 +29,16 @@ check() {
client() {
pkgdesc="SafeKeep backup system - client"
- depends="$pkgname"
+ depends="$pkgname=$pkgver-r$pkgrel"
+
mkdir -p "$subpkgdir"
# just a meta package
}
server() {
pkgdesc="SafeKeep backup system - server"
- depends="$pkgname"
+ depends="$pkgname=$pkgver-r$pkgrel"
+
mkdir -p "$subpkgdir"
mv "$pkgdir"/etc "$subpkgdir"/etc
mkdir "$subpkgdir"/etc/periodic
@@ -48,4 +50,4 @@ package() {
make install DESTDIR="$pkgdir"
}
-sha512sums="d3e69967798035c4f212777069b802d479d9613803a1a68495e761d972ffe2a1b4fdc51da0510e0ebceaf6fbb430305f97ffce8cab5330a4ecbdf68714a35054 safekeep-1.4.5.tar.gz"
+sha512sums="f08c0880ea10bab81dedb8e5601e089344e9a5655a57f0f78d940483bed42c039e62514922c05714a296214d0e7f943cb8da476ee57efc1f7095715af70b3a91 safekeep-1.5.0.tar.gz"